Bug 803879 - build-deploy-jar using incorrect paths to build and find jar
build-deploy-jar using incorrect paths to build and find jar
Status: CLOSED UPSTREAM
Product: GlusterFS
Classification: Community
Component: access-control (Show other bugs)
pre-release
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: M S Vishwanath Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 15:39 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 07:49:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2012-03-15 15:39:25 EDT
Description of problem:
build-deploy-jar in hadoop tools is not using correct paths to build and find jar because of which the tool doesn't work. Also the mvn throwing error because of not finding pom.xml is masked by the use of 'try' statement.

Version-Release number of selected component (if applicable):
git master

How reproducible:
Always
Comment 1 Venky Shankar 2012-03-16 01:02:13 EDT
MS,

An easier way to fix this would be to chdir() the the relevant directory in the script. Then from there on, all paths relative to the current directory would be correct.

In case you have any other idea(s) for the fix; the above looks pretty easy.

Thanks,
-Venky
Comment 2 Anand Avati 2012-03-18 04:41:20 EDT
CHANGE: http://review.gluster.com/2955 (Using correct path to build and find jar file in build_deploy_jar.) merged in master by Anand Avati (avati@redhat.com)
Comment 3 M S Vishwanath Bhat 2012-04-12 07:49:33 EDT
The script is now using proper paths to build and find the jar file.

Note You need to log in before you can comment on or make changes to this bug.