Bug 803884 - nautilus unable to show the content in non root mode
nautilus unable to show the content in non root mode
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 16:01 EDT by Deepak Kumar Mishra
Modified: 2015-03-03 18:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 17:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepak Kumar Mishra 2012-03-15 16:01:18 EDT
Description of problem:
Nautilus does not allow me to browse the removable media when I am a non root user.

Version-Release number of selected component (if applicable):3.2.1


How reproducible:


Steps to Reproduce:
1. I logged in to my linux box using xming from windows and Gnome starts in fall safe mode (not the Gnome 3 new look but the old look)
2. my fstab has the following entry
/dev/mapper/vg_tupsiiv-lv_backup /bkup   vfat    umask=0077,shortname=winnt 0 0

3. Start nautilus and click on the folder /bkup
  
Actual results:
A dialogue comes up says " Folder content could not be displayed" You dont have permission necessary to view the contents of "bkup"


Expected results:


Additional info:

1. I connected one usb external drive and tried to browse Places-> Removable Media -> Free Agent Drive 
it prompts Unable to mount Free Agent Drive "Not Authorized" 

2. There are some other NTFS / Fat 32 partitions in a different Internal HDD which shows up in removable media. If I cluck on any of those it shows Unable to Mount <Mount name> " Authentication is required"

All the above works fine when I have logged in to gnome using root
Comment 1 Tomáš Bžatek 2012-03-20 06:34:21 EDT
Does this work when logged in locally from GDM? Does ls work?

For the first issue it seems polkit-gnome-authentication-agent is not running.
Comment 2 Deepak Kumar Mishra 2012-03-20 10:24:20 EDT
The above was working with Fedora 15. It stopped in Fedora 16 after upgrade..

Other info which I can provide is.. 

Remote log in as root -> I can mount drives every thing works fine
Remote Log in using normal users or member of wheel group ->  can not mount any drive other things work fine
Local log in using normal user ->I can mount drive and everything works fine
Local log in using root -> can not log in


So I am not sure why polkit-gnome-authentication-agent is not working when non root user is logged in from remote.. 

Some how the functionality is broken in Fedora 16.
I tried to do a fresh installation of fedora and the same issue is observed.. that means it is not because of upgrade.. 

But after installation of Fedora 16 + update of packages.. my gnome terminal is crashing.. for which I have logged a bug..  :(

Is there any doc which shows the call flow within gnome shell ? from any gnome app to authentication modules ?
Comment 3 Fedora End Of Life 2013-01-16 13:47:36 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora End Of Life 2013-02-13 17:54:20 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.