Bug 803905 - osapi v1.1 returns errors when getting server status
osapi v1.1 returns errors when getting server status
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-nova (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 18:27 EDT by Steven Dake
Modified: 2016-01-04 09:41 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-nova-2012.1-0.10.rc1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 23:00:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2012-03-15 18:27:20 EDT
Description of problem:
api log attached

Version-Release number of selected component (if applicable):


How reproducible:
openstack-nova-2012.1-0.7.e4.fc16.noarch


Steps to Reproduce:
1. run code in my on disk repo (not yet pushed)
2. I can provide code if needed
3. The essential operation is to post a server (which works) then get the server (which produces the error results)
  
Actual results:
2012-03-15 15:20:55 INFO nova.api.openstack.wsgi [req-86b36a4f-3dfa-4109-8112-14cc108b11e8 app_wordpress sdake] GET http://localhost:8774/v1.1/sdake/servers/26c5e18f-a370-44e1-b5ee-4d1021e8b46f
2012-03-15 15:20:55 ERROR nova.api.openstack [req-86b36a4f-3dfa-4109-8112-14cc108b11e8 app_wordpress sdake] Caught error: Template tree mismatch; adding slave servers to master server
(nova.api.openstack): TRACE: Traceback (most recent call last):
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/__init__.py", line 41, in __call__
(nova.api.openstack): TRACE:     return req.get_response(self.application)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/webob/request.py", line 1053, in get_response
(nova.api.openstack): TRACE:     application, catch_exc_info=False)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/webob/request.py", line 1022, in call_application
(nova.api.openstack): TRACE:     app_iter = application(self.environ, start_response)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 159, in __call__
(nova.api.openstack): TRACE:     return resp(environ, start_response)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/routes/middleware.py", line 131, in __call__
(nova.api.openstack): TRACE:     response = self.app(environ, start_response)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 159, in __call__
(nova.api.openstack): TRACE:     return resp(environ, start_response)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 147, in __call__
(nova.api.openstack): TRACE:     resp = self.call_func(req, *args, **self.kwargs)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/webob/dec.py", line 208, in call_func
(nova.api.openstack): TRACE:     return self.func(req, *args, **kwargs)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 800, in __call__
(nova.api.openstack): TRACE:     content_type, body, accept)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 876, in _process_stack
(nova.api.openstack): TRACE:     request, action_args)

(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 770, in post_process_extensions
(nova.api.openstack): TRACE:     **action_args)
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/compute/contrib/extended_server_attributes.py", line 60, in show
(nova.api.openstack): TRACE:     resp_obj.attach(xml=ExtendedServerAttributesTemplate())
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 493, in attach
(nova.api.openstack): TRACE:     self.serializer.attach(kwargs[self.media_type])
(nova.api.openstack): TRACE:   File "/usr/lib/python2.7/site-packages/nova/api/openstack/xmlutil.py", line 741, in attach
(nova.api.openstack): TRACE:     raise ValueError(msg)
(nova.api.openstack): TRACE: ValueError: Template tree mismatch; adding slave servers to master server
(nova.api.openstack): TRACE:

with a compute error (500) error code produced
Expected results:
server info generated

Additional info:
Comment 1 Steven Dake 2012-03-15 22:46:13 EDT
note taking master of the file:

/home/sdake/repos/nova.git/nova/nova/api/openstack/compute/contrib/extended_server_attributes.py

appears to fix the problem.  It looks like it was rebased today.

Regards
-steve
Comment 2 Pádraig Brady 2012-03-16 00:12:56 EDT
Thanks. I'll look at back porting a fix in the morning.
Comment 3 Pádraig Brady 2012-03-16 14:52:33 EDT
Looks like this 1 character change fixes it:
https://review.openstack.org/#change,5206
Comment 4 Fedora Update System 2012-03-16 19:54:53 EDT
openstack-nova-2012.1-0.8.e4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-nova-2012.1-0.8.e4.fc17
Comment 5 Fedora Update System 2012-03-17 12:49:54 EDT
Package openstack-nova-2012.1-0.8.e4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-nova-2012.1-0.8.e4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3964/openstack-nova-2012.1-0.8.e4.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-03-20 12:07:25 EDT
openstack-nova-2012.1-0.8.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-nova-2012.1-0.8.rc1.fc17
Comment 7 Fedora Update System 2012-03-26 05:15:23 EDT
openstack-nova-2012.1-0.9.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-nova-2012.1-0.9.rc1.fc17
Comment 8 Fedora Update System 2012-03-29 15:01:21 EDT
openstack-nova-2012.1-0.10.rc1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openstack-nova-2012.1-0.10.rc1.fc17
Comment 9 Fedora Update System 2012-04-11 23:00:42 EDT
openstack-nova-2012.1-0.10.rc1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.