This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 803906 - Flex x86_64 RPM shipped with Fedora 16 missing development libraries
Flex x86_64 RPM shipped with Fedora 16 missing development libraries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 18:36 EDT by Dan F
Modified: 2015-05-04 21:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-15 19:04:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan F 2012-03-15 18:36:22 EDT
Description of problem:

I wrote a small program using flex, and compiled it using the flex package installed on the system (flex-2.5.35-13.fc15.x86_64.rpm) plus gcc.  However, I was unable to link because this rpm does not contain anything under /usr/lib or /usr/lib64.  I found older versions of the RPM that contain the expected /usr/lib64/libfl.a.

I checked that the RPM was properly installed, then to double-check I pulled the RPM off my install media, unpacked it as an archive, and looked at the contents and did not find the libfl.a file.  I went to a typical web RPM database and found earlier versions of this package listed, and the contents of these included the expected library under /usr/lib64

Version-Release number of selected component (if applicable):


How reproducible:

Completely

Steps to Reproduce:
1. Install RPM 
2. verify with ls that /usr/lib64/libfl.a is not present
  
Actual results:


Expected results:


Additional info:
Comment 1 Petr Machata 2012-03-15 19:04:47 EDT
That library is distributed in flex-static:

$ rpm -qf /usr/lib64/libfl.a
flex-static-2.5.35-13.fc15.ppc64
$ cat /etc/redhat-release 
Fedora release 16 (Verne)

In Fedora 18 this will be renamed to flex-devel to allow multi-lib installations, but flex-static will be provided by that package as well, so it is safe to depend on it.

Note You need to log in before you can comment on or make changes to this bug.