Bug 80391 - se-latin1 (swedish) keymap is missing
se-latin1 (swedish) keymap is missing
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: kbd (Show other bugs)
phoebe
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
Mike McLean
:
: 78899 81163 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-25 14:31 EST by Tobbe Eriksson
Modified: 2007-04-18 12:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-20 16:20:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobbe Eriksson 2002-12-25 14:31:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
From CD-install, swedish keymap is availible as a choise but after istallation 
during boot -> Loaiding Keymap -FAILED. It seems like there is no se-latin1 
keymaps on installation media.

Ftp-install from network boot-disk, se-latin1 is not listed att all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install From CD or over network, swedish keymap fails.
2.
3.
    

Actual Results:  defaults to us keymap.

Expected Results:  should be able to use a swedish keymap.

Additional info:
Comment 1 Jeremy Katz 2002-12-25 22:59:05 EST
Nalin, any idea what became of the swedish console keymaps?  
Comment 2 David Kvarnberg 2002-12-29 06:46:58 EST
It seems like it got renamed to sv-latin1.map.gz ("sv" instead of "se").
Comment 3 Christian Rose 2003-01-06 13:02:03 EST
The renaming is just plain broken (since when are keyboard layouts named after
language and not country code?).
Comment 4 Bill Nottingham 2003-01-06 17:42:00 EST
*** Bug 81163 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2003-01-16 10:36:28 EST
*** Bug 78899 has been marked as a duplicate of this bug. ***
Comment 6 Henrik Nordstrom 2003-01-22 05:50:59 EST
also redhat-config-keyboard assumes the Swedish keymap is named se-latin1...
Comment 7 Henrik Nordstrom 2003-01-22 06:19:13 EST
Well.. to me renaming to language code makes some sense as there is multiple
languages in the same country and languages spoken in multiple countries.. in
Sweden we have the official Swedish language with it's keymap, but we also have
a couple of other minority languages with their own keymaps possibly shared with
other countries..

However, personally I totally ignore the keymap naming on country vs language,
all I require as a tester is that the same name is used consistently in the
system (which it is not in Phoebe..)
Comment 8 Christian Rose 2003-01-22 12:02:23 EST
Keyboard layouts are usually based on national standards. There is no such thing
as a "language standard". The national keyboard layout standards are however
usually based on the needs for the major languages in that country.

In countries with more than one language the keyboard layout is often the same
everywhere anyway, since they allow for input of the characters of more than one
language. In Spain there isn't a "Spanish" and "Catalan" and "Basque" layout,
it's just the "Spain" layout, which allows for input of all these languages. In
Belgium, there isn't a distinction between a "French" and "Flamish" layout, it's
just the common Belgium layout, which is neither identical to the France nor the
Netherlands layout. And so on.

Because of this, trying to name keyboard layouts after language name is
incredibly broken, since 1) it would give the false impression that keyboard
layouts are per-language which isn't true (English speakers in the US and the UK
usually don't use the same layouts), and 2) it would give the false impression
that you should select the correct layout based on your native language, which
isn't true either (think of a French-speaking Belgian user; he or she should
probably select the Belgium layout and not a "French" one, since the Belgium
keyboard is probably what he or she has).
Comment 9 Pawel Salek 2003-01-22 16:56:15 EST
Is is just me, or the installer sets the /etc/sysconfig/keyboard:KEYTABLE to
se-fi-lat6 which has definetely wrong mappings?
/sbin/setsysfont in the initscript later produces
plus before aring ignored
plus before Aring ignored
plus before odiaeresis ignored
plus before Odiaeresis ignored
plus before adiaeresis ignored
plus before Adiaeresis ignored
Comment 10 Daniel Resare 2003-01-25 15:03:59 EST
Note also the sister bug in rhpl (where the mapping table from Swedish to the
correct X and kbd keyboard layout is) #80508
Comment 11 Christian Rose 2003-01-25 19:09:24 EST
Raising the severity.
With the current broken mapping, which is neither a "se" one nor an "us" one,
it's impossible to enter a colon, so I had to send a kill signal to vim to be
able to even exit from vim... Terrific.
Comment 12 Brent Fox 2003-02-03 14:37:55 EST
Assigning to new owner.
Comment 13 Eido Inoue 2003-02-20 16:20:54 EST
the mapping names have changed after the addition of euro keyboards and latin9.
The warnings above have been fixed for the latest rawhide. the incompatibility
of keymap names between versions and X is a known problem (workaround is to
manually reset the map for now) that will be fixed in the next release. 

Note You need to log in before you can comment on or make changes to this bug.