Bug 803929 - grub2 can't read btrfs-lzo compressed files
grub2 can't read btrfs-lzo compressed files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 22:24 EDT by Paul Alesius
Modified: 2012-04-17 19:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 19:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Alesius 2012-03-15 22:24:02 EDT
Description of problem:
grub2 in fedora 16 does not support lzo and fails to boot if /boot is on btrfs and compressed with lzo (Such as in the case where you have just / and no separate /boot.


How reproducible:
Always


Steps to Reproduce:
1. Install using btrfs as /, no separate /boot
2. edit /etc/fstab and add compress=lzo to /, reboot or mount -o remount / for changes to take effect.
3. Edit grub files in /boot, such as mkconfig -o /boot/grub2/grub.conf
4. Get dropped in grub rescue because the files are compressed on the btrfs filesystem and can't be read by grub2
  
Actual results:
Can't boot if grub files are modified on btrfs with lzo compression


Expected results:
Grub to be able to read its configuration files and such.
Comment 1 Paul Alesius 2012-03-15 22:26:56 EDT
A fix is to boot with a rescue disk that doesn't mount the /boot with compress=lzo, and re-generate the grub files.

Such as with:
grub2-install --root-directory=/ /dev/sd...
/sbin/grub2-mkconfig -i /boot/grub2/grub.conf

The files will be generated without the compression so you will be able to boot, until an update changes some file in /boot while compression is turned on.
Comment 2 Mads Kiilerich 2012-04-17 19:14:18 EDT
Upstream bug http://savannah.gnu.org/bugs/?33287 , so it should be fixed in the grub version used in f17.

A backport to f16 is IMO very unlikely.

Note You need to log in before you can comment on or make changes to this bug.