Bug 803937 - sssd crashed after "LDAP connection error"
sssd crashed after "LDAP connection error"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 23:24 EDT by ksuzuoki
Modified: 2012-06-20 07:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: sssd-1.8.0-15.el6
Doc Type: Bug Fix
Doc Text:
Cause: when IPA client-side migration was performed, the SSSD used the start TLS operation on a connection that was already encrypted by GSSAPI Consequence: In some rare cases, especially when the TLS certificate was not available, this lead to sssd_be process crashing Fix: The migration procedure was fixed so that it spawns a new TLS-only connection for the migration Result: The client side password migration is more robust now
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:56:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Jenny Galipeau 2012-03-16 08:09:30 EDT
Please add steps to reproduce this crash
Comment 5 Jakub Hrozek 2012-03-16 12:27:47 EDT
(In reply to comment #4)
> Please add steps to reproduce this crash

We could never reliably reproduce the crash. There should only be sanity testing of the client-side migration.

The root cause seemed to be the fact that during migration, both TLS and GSSAPI were used at the same time and moreover, TLS was switched on by modifying a global option. We changed the way migration is performed to only use TLS for that single migration connection by passing a flag.

Sumit gave a very detailed overview of the problem along with the proposed solution in the opening comment of https://fedorahosted.org/sssd/ticket/924
Comment 6 Jenny Galipeau 2012-03-16 13:02:38 EDT
Verify sanity only - no regressions found
Comment 11 Jakub Hrozek 2012-04-03 14:49:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: when IPA client-side migration was performed, the SSSD used the start TLS operation on a connection that was already encrypted by GSSAPI

Consequence: In some rare cases, especially when the TLS certificate was not available, this lead to sssd_be process crashing

Fix: The migration procedure was fixed so that it spawns a new TLS-only connection for the migration

Result: The client side password migration is more robust now
Comment 12 Amith 2012-05-29 11:31:49 EDT
Verified on sssd-1.8.0-28.el6.
This bug has been verified sanity only and no related regressions detected.
Comment 14 errata-xmlrpc 2012-06-20 07:56:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.