Bug 804003 - Undocumented socket options for multicast/igmp
Summary: Undocumented socket options for multicast/igmp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-16 09:40 UTC by Radek Pazdera
Modified: 2013-10-23 23:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: undocumented socket options on the ip(7) manual page Consequence: incomplete documentation Fix: document all socket options on the ip(7) manual page Result: complete documentation
Clone Of:
Environment:
Last Closed: 2013-02-21 10:45:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0447 normal SHIPPED_LIVE man-pages bug fix and enhancement update 2013-02-20 20:47:52 UTC

Description Radek Pazdera 2012-03-16 09:40:52 UTC
Description of problem:
Substantial part of kernel multicast/igmp interface is not documented in the relevant manpages (man 7 ip)[1]. It concerns the following socket options:

IP_MSFILTER
IP_ADD_SOURCE_MEMBERSHIP
IP_DROP_SOURCE_MEMBERSHIP
IP_BLOCK_SOURCE
IP_UNBLOCK_SOURCE
IP_MULTICAST_ALL
MCAST_MSFILTER
MCAST_JOIN_GROUP
MCAST_LEAVE_GROUP
MCAST_JOIN_SOURCE_GROUP
MCAST_LEAVE_SOURCE_GROUP
MCAST_BLOCK_SOURCE
MCAST_UNBLOCK_SOURCE

[1] http://www.kernel.org/doc/man-pages/online/pages/man7/ip.7.html

Version-Release number of selected component (if applicable):
Linux man-pages 3.22 (2009-02-28)

How reproducible:
always

Steps to Reproduce:
1. man 7 ip

Additional info:
Someone probably tried to document IP_MULTICAST_ALL[2].

[2] http://patchwork.ozlabs.org/patch/28902/

Comment 3 Peter Schiffer 2012-09-25 12:37:37 UTC
Socket options:

MCAST_MSFILTER
MCAST_JOIN_GROUP
MCAST_LEAVE_GROUP
MCAST_JOIN_SOURCE_GROUP
MCAST_LEAVE_SOURCE_GROUP
MCAST_BLOCK_SOURCE
MCAST_UNBLOCK_SOURCE

are not relevant for this bug, so they won't be documented in the ip(7) man page.

Comment 8 errata-xmlrpc 2013-02-21 10:45:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0447.html


Note You need to log in before you can comment on or make changes to this bug.