Bug 804021 - [abrt] telepathy-butterfly-0.5.15-4.fc16: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/jorg76440_40hotmail_2efr at 0x2a2ae50>
[abrt] telepathy-butterfly-0.5.15-4.fc16: connmgr.py:65:disconnected:KeyError...
Status: CLOSED DUPLICATE of bug 691209
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
abrt_hash:13504341c42fe3d7bf95dc0072b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 06:46 EDT by Jörg BUCHMANN
Modified: 2012-06-28 09:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 09:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jörg BUCHMANN 2012-03-16 06:46:01 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
event_log:      2012-03-16-11:45:46> Smolt profile successfully saved
executable:     /usr/libexec/telepathy-butterfly
kernel:         3.2.9-2.fc16.x86_64
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/jorg76440_40hotmail_2efr at 0x2a2ae50>
time:           ven. 16 mars 2012 10:59:38 CET
uid:            1000
username:       jb

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/jorg76440_40hotmail_2efr at 0x2a2ae50>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 438, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 330, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/jorg76440_40hotmail_2efr at 0x2a2ae50>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0x26aa110>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/jorg76440_40hotmail_2efr at 0x2a2ae50>

smolt_data:
:
:
:Général
:=================================
:UUID: 46f7c004-a4b5-4ac6-9133-4bfd22034961
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: x86_64
:BogoMIPS: 3990.92
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 42
:Nombre de processeurs: 8
:Vitesse du processeur: 2001
:Mémoire du système: 5919
:Swap du système: 6090
:Fabricant: Hewlett-Packard
:Système: HP Pavilion dv6 Notebook PC 058F110000244610000620100
:Type d'ordinateur: Notebook
:Noyau: 3.2.9-2.fc16.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4332:33128:4156:13192) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:7241:4156:13192) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(4332:21001:4156:13192) pci, None, MISC, N/A
:(4147:404:4156:13192) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:278:4156:13192) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4156:13192) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4156:13192) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4156:13192) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(4098:26432:4156:13192) pci, radeon, VIDEO, Whistler XT [AMD Radeon HD 6700M Series]
:(32902:7200:4156:13192) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7188:4156:13192) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7202:4156:13192) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:139:32902:21269) pci, iwlwifi, NETWORK, Centrino Wireless-N 1030 BGN
:(32902:7171:4156:13192) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:4156:13192) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4156:13192) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4156:13192) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4156:13192) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:257:4156:13192) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 7762310 4727177 4649485 1949696 1696947 1696947
:/dev/sdb2 WITHHELD ext4 4096 4096 7338166 6417772 6049939 1839600 1689864 1689864
:/dev/sdb1 WITHHELD fuseblk 4096 4096 236832762 131511259 131511259 526471020 526067580 526067580
:
Comment 1 Prima Yogi Loviniltra 2012-06-28 09:08:44 EDT

*** This bug has been marked as a duplicate of bug 691209 ***

Note You need to log in before you can comment on or make changes to this bug.