Bug 80403 - Fonts not displaying properly
Fonts not displaying properly
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-12-25 17:43 EST by louisgtwo
Modified: 2007-04-18 12:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 08:33:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is what fonts looked like in Psyche (169.93 KB, image/png)
2002-12-26 17:08 EST, Jens Knutson
no flags Details
This is what fonts looked like in Psyche (169.93 KB, image/png)
2002-12-26 17:08 EST, Jens Knutson
no flags Details
This is what fonts look like now, in Phoebe (165.35 KB, image/png)
2002-12-26 17:09 EST, Jens Knutson
no flags Details
Fonts in konsole when using "Preferences -> Font -> Medium". (9.83 KB, image/png)
2003-01-06 02:58 EST, Aleksey Nogin
no flags Details
Fonts in konsole when using "Preferences -> Font -> Medium", under freetype-2.1.3-3 (9.87 KB, image/png)
2003-01-06 03:47 EST, Aleksey Nogin
no flags Details

  None (edit)
Description louisgtwo 2002-12-25 17:43:13 EST
The fonts don't seem as good quality as 8.0, they seem thin and
scraggly, where as 8.0 was nice and bold'ish and good quality.
I believe the same fonts are in use. It may have to do with aa issues.
This is in gnome. I don't know about kde.
Comment 1 Gustav 2002-12-25 19:56:41 EST
I second that. I could also mention that in Mozilla, I have to zoom into 130%
before I can see any differences between normal text and bold text of the same
kind, namely "Sans".
Comment 2 Mike A. Harris 2002-12-26 16:27:32 EST
Font related ugly/pretty issues are generally not XFree86 problems.  They
are generally font configuration problems (of which the XFree86 font
configuration has not changed in ages), or are freetype/fontconfig issues.
Freetype hasn't changed since 8.0 yet, however fontconfig has (although
I have no idea if that could have caused any ugly font issues, I've
certainly not seen any anyway).

Keep in mind that legacy X server fonts are being used less and less,
and client side fonts are being used more and more, which means that
ugly font issues tend to be application specific and not XFree86
related issues.

I'm not sure how exactly to handle a report of "fonts don't look nice"
however.  I've Cc'd Owen in case he is aware of any changes or has
some advice to offer.

Perhaps a not-nice-defining screenshot might help visualize this.
Comment 3 Jens Knutson 2002-12-26 17:07:04 EST
I'm seeing this, too.

I'm attaching a couple screenshots to better demonstrate the differences.

(screenshots lifted from some links on the phoebe mailing list - my fonts look
just the same as the ones from these shots)
Comment 4 Jens Knutson 2002-12-26 17:08:30 EST
Created attachment 88923 [details]
This is what fonts looked like in Psyche
Comment 5 Jens Knutson 2002-12-26 17:08:49 EST
Created attachment 88924 [details]
This is what fonts looked like in Psyche
Comment 6 Jens Knutson 2002-12-26 17:09:31 EST
Created attachment 88925 [details]
This is what fonts look like now, in Phoebe
Comment 7 louisgtwo 2002-12-26 18:01:36 EST
Jens Knutson has good screenshots of the problem. I should mention that I'm
running a radeon 7500 video card with the same resolution. It's possible that
other cards are not effected.
Comment 8 louisgtwo 2002-12-26 18:17:25 EST
Also, this exact thing happened when I upgraded XFree86 on my rh8 box to a
rawhide version (4.2.99.2-0.20021208.1). When I went back to XFree86 stock for
rh8 the font went back to being "nice". So I am %99.99 sure this is a XFree86 bug.
Comment 9 Need Real Name 2002-12-29 22:51:54 EST
I think this is because the "slighthint" patch was not applied to Phoebe's Xft.
 In Psyche, Xft was a separate package maintained by Owen.  In Phoebe,
XFree86-libs has an internal Xft2 library, but the slighthint patch was not
applied AFAIK.  Just take Owen's Xft-2.1 SRPM and apply
Xft-1.9.1.020626.1517-slighthint.patch (and probably
Xft-1.9.1.020811.1151-embeddedbitmap.patch) to XFree86; that would probably do
the trick.  :-)

Note that the current situation with Psyche/Phoebe's
FreeType-2.1.2-with-slighthint-patch is a bit precarious.  (Hmm... perhaps
"precarious" is too strong a word.)  FreeType's upstream author David Turner has
stated that Psyche's variation of FreeType-2.1.2 with slighthint uses deprecated
APIs, and indeed, we see that Psyche and Phoebe's FreeType and dependents (Xft,
etc.) carry corresponding slighthint patches.  This is less than ideal since it
departs from upstream development.  On the other hand, this may be a necessary
(and hopefully temporary) measure to keep the fonts looking their best so that
users won't complain.  ;-)

Cheers,

Anthony
Comment 10 Mike A. Harris 2002-12-30 00:55:48 EST
What I would prefer personally, would be for any changes that are needed
to be made directly by whatever upstream project and us use that, rather
than having special Red Hacks(TM).  The further we diverge from upstream
freetype/XFree86 on stuff like this, the more we have to maintain ourselves,
and it also seems the more projects and people we tend to annoy.

Owen, should I be applying the Xft patches mentioned above? And if so,
have they been submitted upstream yet?

Personally I would prefer if fonts are ugly at all for any reason for anyone
at all, that they are ugly using stock upstream sources, to avoid Blame
Red Hat Syndrome from occuring in the future.
Comment 11 Aleksey Nogin 2003-01-06 02:41:19 EST
I am seing this as well - fonts are extremely ugly for me - both in Mozilla and
the default konsole fonts. Note that I also upgraded 8.0 to Phoebe and I also
have Radeon 7500 - some of that may be a coincidence, but may be not.

In Mozilla case, I have BuildID 2002123101 compiled with Xft support and I used
the same exact binaries under 8.0 and Phoebe, so it's easy for me to see the
ugliness.

I'll try to attach some screenshots.
Comment 12 Aleksey Nogin 2003-01-06 02:58:20 EST
Created attachment 89148 [details]
Fonts in konsole when using "Preferences -> Font -> Medium".

As I understand, this is the font that used to be "Monospace" (although the
"Monospace" is no longer available in font picker, so it might be anything
else).
Comment 13 Jens Knutson 2003-01-06 03:03:27 EST
The current Rawhide freetype RPM (freetype-2.1.3-3) appears to fix this.
Comment 14 Aleksey Nogin 2003-01-06 03:47:30 EST
Created attachment 89149 [details]
Fonts in konsole when using "Preferences -> Font -> Medium", under freetype-2.1.3-3

I've upgraded to freetype-2.1.3-3. Definitely much better, altough some fonts
are still ugly. There still does not appear to be any fully usable font for
konsole (if you need ASCII+cyrillics) - see also bug 68476.
Comment 15 Mike A. Harris 2003-01-07 08:33:54 EST
Closing as resolved in RAWHIDE from 2 comments back.

Note You need to log in before you can comment on or make changes to this bug.