Bug 804049 - mention that SHA256 is used for file digest
mention that SHA256 is used for file digest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Panu Matilainen
Patrik Kis
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 08:00 EDT by Karel Srot
Modified: 2013-02-21 05:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:51:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-03-16 08:00:00 EDT
Description of problem:

rpm-4.8.0-19.el6

rpm manpage is refering to MD5 digests in many places, it is also part of the name of some options. It should be mentioned that rpm is actually using SHA256 hashes. 

      --fileid MD5
              Query package that contains a given file identifier, i.e. the MD5 digest of the  file
              contents.

       --pkgid MD5
              Query package that contains a given package identifier, i.e. the MD5  digest  of  the
              combined header and payload contents.



       Verifying  a  package  compares  information  about  the installed files in the package with
       information about the files taken from the package metadata  stored  in  the  rpm  database.
       Among other things, verifying compares the size, MD5 sum, permissions, type, owner and group
       of each file.  Any discrepancies are displayed.  Files that  were  not  installed  from  the
       package, for example, documentation files excluded on installation using the "--excludedocs"
       option, will be silently ignored.


       S file Size differs
       M Mode differs (includes permissions and file type)
       5 MD5 sum differs
       D Device major/minor number mismatch
       L readLink(2) path mismatch
       U User ownership differs
       G Group ownership differs
       T mTime differs
       P caPabilities differ
Comment 1 Panu Matilainen 2012-03-16 08:56:27 EDT
Rpm uses whatever digest it was configured to use when building packages. RHEL-6 content has SHA256 file digests, older packages have MD5 and 3rd party packages could (although there's not much point in doing so) use something different still. So it's not a case of s/MD5/SHA256/, more like s/MD5/digest/ but it's not that straightforward either as there are places where MD5 is still used, such as the pkgid.

In other words, it's not a straightforward 'perl -pi -e "s/MD5/SHA256/"' job and dunno if it's really worth the trouble for rhel-6 at this point, there are probably more important issues to address. Obviously the terminology should be fixed at least upstream sooner or later.
Comment 2 Karel Srot 2012-03-16 10:06:28 EDT
'perl -pi -e "s/MD5/SHA256/"' is not what I ment. Actually, I think that mentioning that other digest than MD5 are possible would be fine.
Comment 4 RHEL Product and Program Management 2012-07-10 01:53:10 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:51:57 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 RHEL Product and Program Management 2012-08-14 17:59:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 13 errata-xmlrpc 2013-02-21 05:51:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0461.html

Note You need to log in before you can comment on or make changes to this bug.