Bug 804099 - RFE: option for spice display to resize with guest resolution
RFE: option for spice display to resize with guest resolution
Status: CLOSED DUPLICATE of bug 754559
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 10:33 EDT by David Jaša
Modified: 2014-07-06 15:31 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 11:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-03-16 10:33:49 EDT
Description of problem:
spice guest display resize does not work in virt-manager although guest agent is up'n'running and guest resize is enabled by View --> Scale Display --> Always

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-10.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. have a guest with working guest agent
2. in the menu, tick View -> Scale Display -> Always
3. enlarge or shrink the window
  
Actual results:
guest display is only scaled in the client but guest resolution is not updated

Expected results:
guest resolution should be switched to nearest one to the new size of virt-manager viewport

Additional info:
Comment 3 Cole Robinson 2012-03-20 16:41:49 EDT
Scaling is supposed to mean strecthing the guest display for fill the allocated window size. That's how it's always worked for vnc. Spice was incorrectly taking it to mean 'adjust window to guest resolution with guest agent cooperation'.

I added a patch to change the scaling meaning, but this leaves no UI option to enable the guest resize behavior. Enabling that would basically be an RFE. So changing this bug to reflect that.
Comment 5 Cole Robinson 2013-08-17 11:03:19 EDT

*** This bug has been marked as a duplicate of bug 754559 ***

Note You need to log in before you can comment on or make changes to this bug.