Bug 804159 - NLM: Complains of firewall running despite no firewall
NLM: Complains of firewall running despite no firewall
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Divya
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-16 13:18 EDT by Sachidananda Urs
Modified: 2013-07-24 13:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-03-16 13:18:53 EDT
This is possibly due to NAT happening (Have to confirm this yet)...

In that case the log messages have to be more descriptive. Other applications work except for exclusive locks. Basic locking works, but the blocking calls fail.

[2012-03-16 01:53:07.087866] E [nlm4.c:493:nsm_monitor] 0-nfs-NLM: clnt_call(): RPC: Success
[2012-03-16 01:53:07.088445] E [nlm4.c:891:nlm4_establish_callback] 0-nfs-NLM: Unable to get NLM port of the client. Is the firewall running on client?
[2012-03-16 01:53:37.083484] E [nlm4.c:493:nsm_monitor] 0-nfs-NLM: clnt_call(): RPC: Success
[2012-03-16 01:53:37.084042] E [nlm4.c:891:nlm4_establish_callback] 0-nfs-NLM: Unable to get NLM port of the client. Is the firewall running on client?
[2012-03-16 01:54:07.077692] E [nlm4.c:493:nsm_monitor] 0-nfs-NLM: clnt_call(): RPC: Success
[2012-03-16 01:54:07.078286] E [nlm4.c:891:nlm4_establish_callback] 0-nfs-NLM: Unable to get NLM port of the client. Is the firewall running on client?
[2012-03-16 01:54:37.073171] E [nlm4.c:493:nsm_monitor] 0-nfs-NLM: clnt_call(): RPC: Success
[2012-03-16 01:54:37.073635] E [nlm4.c:891:nlm4_establish_callback] 0-nfs-NLM: Unable to get NLM port of the client. Is the firewall running on client?
[2012-03-16 01:55:07.067772] E [nlm4.c:493:nsm_monitor] 0-nfs-NLM: clnt_call(): RPC: Success
[2012-03-16 01:55:07.068245] E [nlm4.c:891:nlm4_establish_callback] 0-nfs-NLM: Unable to get NLM port of the client. Is the firewall running on client?
[2012-03-16 01:55:37.105924] E [nlm4.c:493:nsm_monitor] 0-nfs-NLM: clnt_call(): RPC: Success
Comment 1 Krishna Srinivas 2012-03-19 01:38:22 EDT
Explained the problem to sac that the problem was happening because of the NAT router. Gluster NLM server was trying to do portmap query of NLM on the client and failing (gluster NLM server would think that the NAT router is the client - because of NAT'ing). For NLM to work properly there should not be NAT or firewall between the server and the client.
Comment 2 Sachidananda Urs 2012-04-04 03:20:20 EDT
We should be documenting this before closing the bug. I will update the bug and add a pointer to documentation if I can get a pointer.

Till then we can keep the bug as open.
Comment 3 Vijay Bellur 2012-04-27 08:12:46 EDT
Divya,

Can you please confirm if the documentation is complete?

Thanks
Comment 4 Divya 2012-05-04 06:05:55 EDT
I have added it as Known Issue in Release Notes. The updated Release Notes is available at: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Storage/2/html/2.0_Release_Notes/chap-2.0_Release_Notes-Test_Chapter.html
Comment 5 Sachidananda Urs 2012-05-21 01:37:42 EDT
Documentation verified.

Note You need to log in before you can comment on or make changes to this bug.