Bug 804184 - Should use a USB icon instead of a generic settings icon
Summary: Should use a USB icon instead of a generic settings icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 808057 921406
TreeView+ depends on / blocked
 
Reported: 2012-03-16 19:02 UTC by Marc-Andre Lureau
Modified: 2016-04-26 14:13 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.6.0-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 921406 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:28:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
USB redirection icon (1.16 MB, image/png)
2013-05-16 12:41 UTC, Marc-Andre Lureau
no flags Details
USB redirection dialog (1022.23 KB, image/png)
2013-05-16 12:42 UTC, Marc-Andre Lureau
no flags Details
24x24px usb icon (1.07 KB, image/png)
2013-09-04 13:50 UTC, Jakub Steiner
no flags Details
source SVG (9.19 KB, image/svg+xml)
2013-09-04 13:50 UTC, Jakub Steiner
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1379 0 normal SHIPPED_LIVE virt-viewer bug fix update 2014-10-14 01:05:43 UTC

Description Marc-Andre Lureau 2012-03-16 19:02:01 UTC
In fullscreen, the toolbar contains a button with a generic settings icon for USB redirection. It would be nicer to use a USB icon for USB device redirection dialog.

Comment 4 RHEL Program Management 2012-07-10 08:50:09 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Program Management 2012-07-11 02:00:21 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 6 Daniel Berrangé 2012-07-26 17:19:12 UTC
This sounds like a pretty straightforward thing to fix. Just need to browse one of the license compatible icons sets like Tango, to find a good match.

Comment 8 Marc-Andre Lureau 2013-05-16 12:41:57 UTC
Created attachment 748804 [details]
USB redirection icon

Comment 9 Marc-Andre Lureau 2013-05-16 12:42:41 UTC
Created attachment 748807 [details]
USB redirection dialog

Comment 10 Marc-Andre Lureau 2013-05-16 12:46:41 UTC
Jakub, could you help us find or design the right icon for the job? Or if you have other solution to propose.

It's an button icon shown in the full overlay toolbar of virt-viewer to open up the USB redirection dialog, see attached screenshots.

thanks

Comment 15 Jakub Steiner 2013-09-04 13:50:26 UTC
Created attachment 793682 [details]
24x24px usb icon

I don't think the logo works particularly, but here goes.

Comment 16 Jakub Steiner 2013-09-04 13:50:51 UTC
Created attachment 793684 [details]
source SVG

Comment 18 Marc-Andre Lureau 2014-03-12 21:35:14 UTC
taking

Comment 19 Marc-Andre Lureau 2014-03-12 21:39:05 UTC
moving to POST:
https://www.redhat.com/archives/virt-tools-list/2014-March/msg00085.html

Comment 22 zhoujunqin 2014-06-09 07:59:20 UTC
I can reproduce with package: virt-viewer-0.5.6-10.el6.x86_64
and verified with new build: virt-viewer-0.6.0-5.el6.x86_64

steps:
1.prepare a guest with usbredirection support.

1.1 Prepare a .cfg file in /etc/qemu:

# cat ich9-ehci-uhci.cfg

###########################################################################
#
# You can pass this file directly to qemu using the -readconfig
# command line switch.
#
# This config file creates a EHCI adapter with companion UHCI
# controllers as multifunction device in PCI slot "1d".
#
# Specify "bus=ehci.0" when creating usb devices to hook them up
# there.
#

[device "ehci"]
  driver = "ich9-usb-ehci1"
  addr = "1d.7"
  multifunction = "on"

[device "uhci-1"]
  driver = "ich9-usb-uhci1"
  addr = "1d.0"
  multifunction = "on"
  masterbus = "ehci.0"
  firstport = "0"

[device "uhci-2"]
  driver = "ich9-usb-uhci2"
  addr = "1d.1"
  multifunction = "on"
  masterbus = "ehci.0"
  firstport = "2"

[device "uhci-3"]
  driver = "ich9-usb-uhci3"
  addr = "1d.2"
  multifunction = "on"
  masterbus = "ehci.0"
  firstport = "4"


1.2 Create a new spice-enabled vm using virt-manager, select spice as display type and qxl as video card model, when asked if you want to enable the agent channel, say yes.

1.3 When done, close virt-manager and edit the relevant /etc/libvirt/qemu/sound.xml file. Change the first line to:

<domain type='kvm' xmlns:qemu='http://libvirt.org/schemas/domain/qemu/1.0'>
And add the following lines at the end, above the "</domain>" line: 

  <qemu:commandline>
     <qemu:arg value='-readconfig'/>
     <qemu:arg value='/etc/qemu/ich9-ehci-uhci.cfg'/>
     <qemu:arg value='-chardev'/>
     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev1'/>
     <qemu:arg value='-device'/>
     <qemu:arg value='usb-redir,chardev=usbredirchardev1,id=usbredirdev1,bus=ehci.0,debug=3'/>
     <qemu:arg value='-chardev'/>
     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev2'/>
     <qemu:arg value='-device'/>
     <qemu:arg value='usb-redir,chardev=usbredirchardev2,id=usbredirdev2,bus=ehci.0,debug=3'/>
     <qemu:arg value='-chardev'/>
     <qemu:arg value='spicevmc,name=usbredir,id=usbredirchardev3'/>
     <qemu:arg value='-device'/>
     <qemu:arg value='usb-redir,chardev=usbredirchardev3,id=usbredirdev3,bus=ehci.0,debug=3'/>
  </qemu:commandline>

1.4 close down any virtual machines you may have open , and restart libvirtd
 # service libvirtd restart

2. use virt-viewer to open an existing guest.
# virt-viewer sound
or
# remote-viewer spice://ip:port

3. click view->full screen
we can see USB icon for USB device redirection "USB device selection".

so changed from "ON_QA" to "VERIFIED".

Comment 23 errata-xmlrpc 2014-10-14 06:28:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html


Note You need to log in before you can comment on or make changes to this bug.