Bug 804205 - Allocate a 'elasticsearch' username and groupname
Allocate a 'elasticsearch' username and groupname
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: setup (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.3
Assigned To: Ondrej Vasik
qe-baseos-daemons
:
Depends On:
Blocks: 750334
  Show dependency treegraph
 
Reported: 2012-03-16 16:14 EDT by Justin Sherrill
Modified: 2012-06-20 08:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: setup-2.8.14-15.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:23:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-03-16 16:14:40 EDT
Description:


For the upcoming system engine product, we need a reserved user and group of
'elasticsearch' for the service we are running. 


homedir:  /usr/share/java/elasticsearch
package that creates it:  elasticsearch
Comment 1 Ondrej Vasik 2012-03-17 02:35:49 EDT
Do you really need this static id reservation? Rpmdiff failure is only indicator - static id is required for network facing/communicating system accounts and daemons handling sensitive data - is it the case of this system account? If not, rpmdiff failure could be waived (static id range is limited).
Comment 3 Justin Sherrill 2012-03-19 09:57:43 EDT
Hey Ondrej,


"Rpmdiff failure is only indicator - static id is required for network facing/communicating system accounts and daemons handling sensitive data"

I believe this is the case.  This is a network service that is holding user and system information, so I would consider that 'sensitive data'.

I don't know that this is Z-stream worthy either.  As long as a UID is picked, we can use that UID knowing it will be reserved in the future.  

Thanks,

-Justin
Comment 4 Ondrej Vasik 2012-03-19 10:33:22 EDT
Thanks, I'll reserve 183:183 for elasticsearch. Removing z-stream request...
Comment 12 errata-xmlrpc 2012-06-20 08:23:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0778.html

Note You need to log in before you can comment on or make changes to this bug.