Bug 80421 - Error mounting /dev/loop0
Error mounting /dev/loop0
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
http://web.ics.purdue.edu/~hartlerl/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-25 21:39 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 16:27:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-12-25 21:39:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Although not my page, the url I submitted describes the exact same problem I
had. (the description is at the bottom of the page in blue text at the time I'm
submitting this). 

I downloaded iso images from a mirror, and the md5 checksums were okay. Although
disc 1 booted fine, when it asked me which method to use to install, and I chose
cdrom, it couldn't find the cdrom it had just booted from. Looking at the other
ttys, there were a series of errors where the cdrom had tried to read beyond the
media (don't have exact error message), and so I tried an http install and then
an ftp install. In both those cases, I got the "Error mounting /dev/loop0 on
/mnt/runtime (Device or resource busy). This shouldn't happen and I'm rebooting
your system now." message.

The box I was attempting to install on was my girlfriend's dads. I do not have
access to the computer after tonight, so probably can't give much followup on
this bug (sorry!). The box has 2 hard drives, a dvd/cd drive, and a tape drive -
two ide controllers, with a master and slave on each. It is an older Dell
Dimension box, and he added the dvd/cd drive.

I attempted to boot linux ide=nodma and boot linux hdc=cdrom, with the same results.

For some reason, it seems that the loopback device doesn't work RedHat 8.0 on
this box.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put in install CD 1
2. Boot computer, select english language and us keyboard. select cdrom install,
or http install, or ftp install
3. computer doesn't recognize cd, or fails to initialize loopback device, so pukes.
    

Actual Results:  puked.

Expected Results:  a beautiful, easy, nice redhat 8.0 install to impress my
girlfriend's dad, who is an experienced windows guy who is sick of windows.

Additional info:
Comment 1 Michael Fulbright 2002-12-27 11:20:50 EST
You did test all the CD's with the internal mediacheck?
Comment 2 Need Real Name 2003-01-01 14:46:39 EST
I did a boot: linux mediacheck on the first cd, but no others. I didn't get any
errors, but it just proceeded to the normal boot process, so I'm not convinced
it really did do the check. MD5 checksums on the iso downloads worked.

However, since I also tried an ftp install from a mirror, and an http install
from my iso images, I don't think the media are the problem.
Comment 3 Michael Luich 2003-01-02 20:36:31 EST
Same problem here. 

Some more Information:

The error message states:

Error mounting /dev/loop1 on 
/mnt/runtime (Invalid argument).
This shouldn't happen, and I'm
rebooting your system now

Virtual console 3 (Last 2 lines):
mntloop loop1 on /mnt/runtime as /tmp/ramfs/hdstg1.img fd is 10
failed to mount loop: Invalid argument

(before that it seems to mount and unmount the ISO image sucessfully)

Virtual console 4:
<6>attempt to access beyond end of device
<6>07:00: rw=0, want=571978, limit =278776
<6>attempt to access beyond end of device
<6>07:00: rw=0, want=571980, limit =278776
<4>Unable to identify CD-ROM format.
<4>VFS: Can't find ext2 filesystem on dev loop(7,1).
<3>cramfs: wrong magic

Comment 4 Jeremy Katz 2003-01-10 02:20:14 EST
If it does the check, you should see a progress bar as it checks the CDs.  Did
you see this?
Comment 5 Need Real Name 2003-01-10 08:37:30 EST
No, I did not, but again, since I also tried an ftp install from a mirror, and
an http install from my iso images, I don't think the media are the problem.

The md5 on my iso images was correct, but I can do a mediacheck on the cd's -
I'll do it some time next week.
Comment 6 Jeremy Katz 2003-01-11 01:55:03 EST
The ISOs being fine doesn't mean that you didn't get a bad batch of media. 
Unfortunately, the quality of recordable CDs seems to be dropping :(  If you
could check this next week, that would be very helpful
Comment 7 Need Real Name 2003-01-18 14:31:17 EST
I attempted to do a boot: linux mediacheck and it just booted as if for the
normal boot process. No Progress bar that I saw, it just started the graphical
install and asked which language I'd like to use.

FYI, I am now trying it with a different set of media, on a second computer with
the same results.

Next, I'll try burning the cds with a different burner to see if I get different
results.
Comment 8 Need Real Name 2003-01-18 14:39:58 EST
I just came across these URLs with some more people having the same problem

http://www.computing.net/linux/wwwboard/forum/16089.html
http://www.kuro5hin.org/story/2003/1/13/8153/32749

on kuro5hin, different media worked for him. I'll try grabbing new isos and
burning new disks soon.
Comment 9 Need Real Name 2003-01-18 15:31:56 EST
Bad Media.

I burned the iso to a new cdrom here on my linux box, and mediacheck loaded and
worked as it should. The media I burned worked. The older media (which I burned
at my gf's dad's house <paranoia>on a windows XP box</paranoia> didn't pass the
media check.

Perhaps it might be worth adding a note to the docs that if boot: linux
mediacheck  doesn't give the status bar, it fails.

Note You need to log in before you can comment on or make changes to this bug.