Bug 804225 - ruby 1.9.1, ubuntu - rhc-create-domain -a flag doesn't create default ssh key
ruby 1.9.1, ubuntu - rhc-create-domain -a flag doesn't create default ssh key
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 18:03 EDT by Nam Duong
Modified: 2015-05-14 21:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-03-16 18:03:34 EDT
Description of problem:
This is a basement corner case that's worth logging.  We have a user (Gabriel) that is using OpenShift to get away from Heroku's $70/mo bill.  S/He's on Ubuntu and Ruby 1.9.1.

When I walked him through synching up his public key to his domain with:
  >> rhc-domain-create -n <namespace> -l <RHLogin> -a
it came back with:

OpenShift Express key found at /home/gabriel/.ssh/libra_id_rsa.  Reusing... Submitting form: rhlogin: gabrielwu84@gmail.com debug: true Contacting https://openshift.redhat.com Response from server: DEBUG:   Exit Code: 0 broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartridge", "cart_type", "action", "app_name", "api"] api_c: ["placeholder"] API version:    1.1.2 Submitting form: namespace: gabrielwu84 

ERROR: Key name 'default' doesn't exist for user gabrielwu84@gmail.com

The workaround was to manually add the public key.
Comment 1 Nam Duong 2012-03-16 18:06:14 EDT
To add, he used the Web UI to create the domain, so it doesn't initially have a default key.

FWIW:  I've installed v1.9.2 on Mac OSX via rvm and wasn't able to reproduce this.  I was able to reproduce the fact that on ruby 1.9.x, gem install test-unit is necessary to run rhc-chk.
Comment 2 John (J5) Palmieri 2012-03-29 21:14:06 EDT
Filing as low because it hasn't been reproduced and the initial issue was worked around using the web UI
Comment 3 Mike McGrath 2012-05-15 12:45:10 EDT
This might have been an older bug.  Try to recreate it one more time, if it's still working for you, close as worksforme.  

Raising severity so it gets closed in this release.
Comment 4 Peter Ruan 2012-05-15 18:18:08 EDT
works for me when I run it in my Ubuntu installation.

Note You need to log in before you can comment on or make changes to this bug.