Bug 80423 - (savage mx) video server not initialized properly upon cold boot on Toshiba 2805 laptop
(savage mx) video server not initialized properly upon cold boot on Toshiba 2...
Status: CLOSED DUPLICATE of bug 80346
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-25 22:14 EST by Florin Iucha
Modified: 2008-01-17 12:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 config file generated by the installer (3.14 KB, text/plain)
2002-12-26 21:01 EST, Florin Iucha
no flags Details
XFree86 startup log (30.14 KB, text/plain)
2002-12-26 21:07 EST, Florin Iucha
no flags Details

  None (edit)
Description Florin Iucha 2002-12-25 22:14:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
When I do a cold boot into RedHat Linux (Phoebe) and the X starts, the image on
the screen is garbled: the background is dark and only the mouse pointer is
shown. The mouse pointer leaves persistent trails when moved.
When I boot first in Debian (which uses XFree 4.2.1) and then reboot into RedHat
the greeter appears fine and I can log in into an user account.

The relevant section from /etc/X11/XF86Config:
Section "Device"
        Identifier  "Videocard0"
        Driver      "savage"
        VendorName  "Videocard vendor"
        BoardName   "S3 Savage/MX"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Modes    "800x600"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

It happens even if I change the color depth to 16.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do an install, choose graphical login
2. Shut down the computer.
3. Start up the computer.
    

Actual Results:  Screen is garbled.

Expected Results:  Screen properly displays greeter.

Additional info:
Comment 1 Mike A. Harris 2002-12-26 20:55:27 EST
Please attach the complete X server log file and config file, uncompressed,
using the link below.
Comment 2 Florin Iucha 2002-12-26 21:01:25 EST
Created attachment 88929 [details]
XFree86 config file generated by the installer
Comment 3 Florin Iucha 2002-12-26 21:07:10 EST
Created attachment 88931 [details]
XFree86 startup log

I had started up RedHat both cold and warm (reboot from Debian). The 
/var/log/XFree86.0.log files are identical except for the time stamp.
Comment 4 Mike A. Harris 2002-12-26 21:20:24 EST
XFree86-Servers does not exist, it is "XFree86" component.  Changing component.
Comment 5 Mike A. Harris 2002-12-27 14:27:56 EST
Please try adding the "noaccel" option to the device section of your
XFree86 config file.  If that makes the problem go away, we will refine
our troubleshooting and narrow it down.

Comment 6 Florin Iucha 2002-12-28 19:54:40 EST
Adding the noaccel option makes the problem go away.
Comment 7 Mike A. Harris 2002-12-29 05:06:11 EST
Ok, now remove the noaccel option, and instead, try using the XaaNoxxxxxx
options that are listed on the XF86Config manpage.  Try them one at a time
to see if any one option makes the problem go away.  If not, try 2 at
a time.  If you can narrow down a minimum number of options which resolve
the problem, please update the report and I will let the driver author
know where the problems lay for this hardware in hopes he can fix it for
4.3.0.

Thanks
Comment 8 Florin Iucha 2002-12-29 11:45:24 EST
Huh, you are kidding, right? 18 * 18 combinations to test?

Oh, well, I have tried two combinations and here are the results:

Options:
        #Option         "noaccel"
        #Option "XaaNoCPUToScreenColorExpandFill"
        #Option "XaaNoColor8x8PatternFillRect"
        #Option "XaaNoDashedBresenhamLine"
        #Option "XaaNoDashedTwoPointLine"
                                                                                
        #Option "XaaNoImageWriteRect"
        #Option "XaaNoMono8x8PatternFillRect"
        #Option "XaaNoMono8x8PatternFillTrap"
        #Option "XaaNoOffscreenPixmaps"
                                                                                
        #Option "XaaNoPixmapCache"
        Option "XaaNoScanlineCPUToScreenColorExpandFill"
        Option "XaaNoScanlineImageWriteRect"
        Option "XaaNoScreenToScreenColorExpandFill"
                                                                                
        Option "XaaNoScreenToScreenCopy"
        Option "XaaNoSolidBresenhamLine"
        Option "XaaNoSolidFillRect"
        Option "XaaNoSolidFillTrap"
                                                                                
        Option "XaaNoSolidHorVertLine"
        Option "XaaNoSolidTwoPointLine"
                                                                                
Outcome:
        gdm greeter screen has no images, only an edit box (which has whiter
background than the rest of the screen).
        GNOME desktop appears fine
        Mozilla is fine, scrolling is slow
        Evolution is fine
                                                                                
----------------------------
                                                                                
Options:
        #Option         "noaccel"
        Option "XaaNoCPUToScreenColorExpandFill"
        Option "XaaNoColor8x8PatternFillRect"
        Option "XaaNoDashedBresenhamLine"
        Option "XaaNoDashedTwoPointLine"
                                                                                
        Option "XaaNoImageWriteRect"
        Option "XaaNoMono8x8PatternFillRect"
        Option "XaaNoMono8x8PatternFillTrap"
        Option "XaaNoOffscreenPixmaps"
                                                                                
        Option "XaaNoPixmapCache"
        #Option "XaaNoScanlineCPUToScreenColorExpandFill"
        #Option "XaaNoScanlineImageWriteRect"
        #Option "XaaNoScreenToScreenColorExpandFill"
                                                                                
        #Option "XaaNoScreenToScreenCopy"
        #Option "XaaNoSolidBresenhamLine"
        #Option "XaaNoSolidFillRect"
        #Option "XaaNoSolidFillTrap"
                                                                                
        #Option "XaaNoSolidHorVertLine"
        #Option "XaaNoSolidTwoPointLine"
                                                                                
Outcome:
        gdm greeter: normal
        GNOME desktop: normal
        Evolution: all the menus are transparent, displaying what is actually
underneath
        Mozilla: scrolling is all messed up but the menus are ok
Comment 9 Alexandre Oliva 2003-01-03 08:28:12 EST
Before I overwrite the 8.0 install on my S3 Savage/MX laptop with Phoebe: I've
got it working with XFree86-4.2.99.1-0.20021018.1, without any options set or
reset in XF86Config.
Comment 10 Alexandre Oliva 2003-01-03 18:58:13 EST
For gdm to display the login screen properly:
        Option "XaaNoImageWriteRect

For the gdm screen to be cleared before the ssh-ask-password window is opened,
and for the gnome start-up screen to be displayed properly:
        Option "XaaNoSolidFillRect"

For gnome-terminal contents to be displayed properly, especially when the window
is moved or partially covered/uncovered:
        Option "XaaNoScreenToScreenCopy"

For GNU Emacs menus and xchat gray-on-black contents to display correctly:
        Option "XaaNoScanlineCPUToScreenColorExpandFill"

For the border of the Back/Next/Cancel buttons in evolution's start-up screen to
be displayed:
        Option "XaaNoMono8x8PatternFillRect"

However, even with noaccel, the traditional X cursor is displayed after login,
and even in the login screen after a switch to a text VC and back, right in the
center of the screen, atop of everything, and it remains there until X is
terminated, without anything ever being able to get me rid of it.   Suggestions?
Comment 11 Florin Iucha 2003-01-03 19:36:48 EST
Use KDE. Seriously, the problem occurs only in Gnome.
Comment 12 Alexandre Oliva 2003-01-03 19:56:49 EST
To me, this only implies that there's room for improvement in KDE, for it to
take advantage of acceleration in cases that it doesn't :-)
Comment 13 John Murga 2003-01-07 05:14:14 EST
I get the problem with KDE too, the fix does work though.

Disabling gpm also seems to get rid of the X cursor for me...
Comment 14 Thomas M Steenholdt 2003-01-20 13:39:47 EST
I'm having a similar problem with an "S3 Savage/MX" adapter during
installation...  X seems to start correctly, but only the mouse cursor seems to
be intact... the background stays garbled with the remains of what the BIOS
displayed before linux was booted. As a result graphical install is not possible...

I tried linux lowres and linux resolution=1024x768 with no significant changes
and certainly without success.
Comment 15 Thomas M Steenholdt 2003-01-20 13:40:40 EST
I should mention that what I posted above applies to Phoebe - BETA4 8.0.93
Comment 16 Thomas M Steenholdt 2003-01-21 05:57:48 EST
I'm also having problems with X after installation - GDM arrears no-so-garbled
at first, but with strange redish borders. When logging in, the screen looks
like a TV with week reception. navigatable, but very very noisy and butt ugly!

i have tried with Option "noaccel" with no change in behaviour
Comment 17 Mike A. Harris 2003-01-21 06:08:43 EST
I've pinged the upstream driver maintainer to see if he might have a fix
for this problem on Savage/MX in current CVS XFree86.

Worst case, if we don't find a fix before our final release, I'll change the
default driver for this one chip to "vesa" so that there is working video
out of the box.

Can someone test "vesa" out in the mean time and provide comments back on
wether it works or not?
Comment 18 Thomas M Steenholdt 2003-01-21 06:28:10 EST
The vesa driver seems to work just fine here!
Comment 19 Panu Matilainen 2003-01-21 06:30:48 EST
Vesa works fine here with IBM T21 (S3 Inc. 86C270-294 Savage/IX-MV (rev 13)) and
the performance is at least tolerable.
Alexandres list of XaaNo... options also makes it work, only window moving in
painful because of the redraw slowness, "shadowfb" helps somewhat in that case.
Comment 20 Alexandre Oliva 2003-01-23 10:53:34 EST
John Murga says:

> Disabling gpm also seems to get rid of the X cursor for me...

This is no longer necessary in Phoebe2.

The need for disabling a number of acceleration options is still there, though.
Comment 21 Mike A. Harris 2003-01-24 01:37:03 EST
I believe this is a duplicate of bug #80346

Could everyone please examine that bug report, and the ones duped against
it, and comment on it.  Please test the driver suggested in the report
as well and let me know if it resolves the issues for you all.
Comment 22 Thomas M Steenholdt 2003-01-24 08:37:54 EST
In't very likeli that this report and 80346 are regarding the same issue.
However I'm not experiencing quite the same problems, it seems, the only
workaround that has worked for me, has been using the vesa driver.
I'v also not been able to successfully have the updated driver installed for
test and so i can't see if that fixes my problems as well, until the source for
that module can be provided. (I'm getting unresolved symbol error and X aborts
after that)
Comment 23 Thomas M Steenholdt 2003-01-24 15:02:30 EST
As far as I'm concerned, this bug is a duplicate of bug #80346...

I have installed the suggested driver and it eliminated all the display problems
that I was having.
Comment 24 Mike A. Harris 2003-01-24 15:35:46 EST

*** This bug has been marked as a duplicate of 80346 ***
Comment 25 Red Hat Bugzilla 2006-02-21 13:50:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.