Bug 804241 - SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a process.
SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a pr...
Status: CLOSED DUPLICATE of bug 804237
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-03-16 19:42 EDT by Horst H. von Brand
Modified: 2012-03-17 06:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-03-17 06:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2012-03-16 19:42:07 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a process.
time:           Fri 16 Mar 2012 07:41:52 PM CLT

:SELinux is preventing /usr/bin/Xorg from using the 'getpgid' accesses on a process.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that Xorg should be allowed getpgid access on processes labeled xdm_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Objects                 [ process ]
:Source                        Xorg
:Source Path                   /usr/bin/Xorg
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xorg-x11-server-Xorg-1.11.4-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.7-1.fc16.x86_64 #1
:                              SMP Tue Feb 21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 16 Mar 2012 07:30:25 PM CLT
:Last Seen                     Fri 16 Mar 2012 07:30:25 PM CLT
:Local ID                      c47f5c65-2f97-4500-9d6a-3bed99131946
:Raw Audit Messages
:type=AVC msg=audit(1331940625.86:98): avc:  denied  { getpgid } for  pid=1328 comm="Xorg" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=process
:type=SYSCALL msg=audit(1331940625.86:98): arch=x86_64 syscall=getpgid success=no exit=EACCES a0=4f1 a1=0 a2=18 a3=0 items=0 ppid=1265 pid=1328 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
:Hash: Xorg,xdm_t,xdm_t,process,getpgid
:#============= xdm_t ==============
:allow xdm_t self:process getpgid;
:audit2allow -R
:#============= xdm_t ==============
:allow xdm_t self:process getpgid;
Comment 1 Daniel Walsh 2012-03-17 06:52:42 EDT

*** This bug has been marked as a duplicate of bug 804237 ***

Note You need to log in before you can comment on or make changes to this bug.