Bug 804245 - "Match my system" checkbox has a long delay to have any effect
"Match my system" checkbox has a long delay to have any effect
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
: Triaged
Depends On: 771757
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 20:08 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Chrome 17
Last Closed: 2012-11-01 13:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2012-03-16 20:08:34 EDT
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.304-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. See comment #6 in upstream bug (see "depends on") (copied here):

create a system w/ a fact of 64 cpu sockets and view that
system using a manifest w/ a product that covers less sockets. Toggling
checkbox will now show the lesser socket subscriptions where previously they
were not shown.
  
Actual results:
See comment #9 in upstream bug (copied here):
there is an unacceptable delay between the time you check
the checkbox, and when the list updates.  Nothing indicates to the user that
the app is busy. The "working" cursor appears for about 1/2 second, the normal
cursor returns, and then finally the list updates about 4 seconds later.  

That's enough time for a user to figure the content isn't there and navigate away.

Expected results:
"Working" cursor stays until list is updated.


Additional info:
Comment 1 Tom McKay 2012-11-01 13:43:23 EDT
"match my system" style changed and spinner added (where before it would give no indication that an ajax call had been made)
Comment 2 Mike McCune 2013-08-16 14:00:31 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.