Bug 804264 - Cannot install FC17 i686 from Live CD to partition smaller than 4096 Meg
Cannot install FC17 i686 from Live CD to partition smaller than 4096 Meg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 01:26 EDT by Fred J. Tydeman
Modified: 2012-03-19 13:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 13:51:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred J. Tydeman 2012-03-17 01:26:00 EDT
Description of problem:
Cannot install to a '/' partition smaller than 4096 Meg

Version-Release number of selected component (if applicable):
Fedora Core 17 alpha Live CD

How reproducible:
Always

Steps to Reproduce:
Downloaded the alpha Fedora Desktop Live Media via an existing FC15 system.  Used Fedora LiveUSB creator to put it on a USB memory stick.  Booted that USB memory stick.  Ran Install to hard disk.  Picked a custom disk layout to use a 2008 meg swap partition and a 4016 meg '/' partition.  That gets an error that '/' must be at least 4096 meg.

Please turn that hard error into a warning and let me continue with the install.

Cylinders/Heads/Sectors that different OSes would like:
C/H/S */240/63 = OS/2, eCS and older Windows
C/H/S */255/63 = Linux

Since 240 = 15*16 and 255 = 15*17, the number 15*16*17 is the magic
number of C/H to use for partitions.  Since each head is 63 sectors,
and each sector is 512 bytes, 15*16*17*63*512 works out to 125.5 meg.
Therefore, if every partition is a multiple of 125.5 meg, each
partition will appear to be on a cylinder boundary to OS/2, eCS, all older
Windows, and Linux.

125.5 meg * 32 = 4016 meg is the size of partitions I use for Linux.
I use partitions of size 1004, 2008, 4016, 16064 meg.

The last time I hit this problem, I installed the SOAP desktop version of Fedora Core (since it installs to a smaller '/' partition), and then added the gnome desktop.

Actual results:
A hard error about a small '/' partition that stops install.

Expected results:
A warning about a small '/' partition and then let me continue with the install.

Additional info:
Comment 1 Fred J. Tydeman 2012-03-17 01:32:39 EDT
SOAP in the above should be SOAS (Sugar on a Stick)
Comment 2 Chris Lumens 2012-03-19 13:51:04 EDT
We don't do anything with CHS here.  We run a program to determine how big the live image is, and get a size back in MB.  We then check that against how big you've decided to make the drive.  Turning this into a warning is just going to lead to us getting weirder bugs in the future from people who choose to ignore it and continue on.

Note You need to log in before you can comment on or make changes to this bug.