Bug 804276 - Jenkins builds fail the first few times after migration
Jenkins builds fail the first few times after migration
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 04:38 EDT by Rob Millner
Modified: 2015-05-14 18:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-03-17 04:38:59 EDT
After migration from 2.0.6 to 2.0.7, Jenkins application builds fail.

Logging into the Jenkins console and retrying the build a few times or waiting a long time seems to resolve the issue (a new builder gear).

Since the problem goes away on its own, calling this a medium.
Comment 1 Rob Millner 2012-03-17 04:43:59 EDT
This should have been addressed by commit 2aa3651, but there's something which is temporarily holding on to the old value.

The slave.jar process may be the culprit.
java -jar /var/lib/libra/65579fd16efd43fe84a8dd085398c809/rlm7stg4bldr/data//jenkins/slave.jar

Its environment remains static from the time of launch.
Comment 2 Rob Millner 2012-03-22 22:35:31 EDT
We're passed the post-migration window for this issue to show up and doesn't have appeared to affect anybody.
Comment 3 Meng Bo 2012-03-29 22:56:28 EDT
Verified with latest migration scripts on devenv_1679.
Issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.