Bug 804308 - Cursor is displayed on each guest screen when mouse is in server mode.
Cursor is displayed on each guest screen when mouse is in server mode.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 13:05 EDT by Marian Krcmarik
Modified: 2012-06-20 08:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Two cursors (341.15 KB, image/png)
2012-03-17 13:05 EDT, Marian Krcmarik
no flags Details

  None (edit)
Description Marian Krcmarik 2012-03-17 13:05:40 EDT
Created attachment 570814 [details]
Two cursors

Description of problem:
Cursor is displayed on each guest screen when mouse is in server mode - see attached screenshot as an example. It's possible to move mouse in all guest screens but cursor is displayed on each of them, This did not happen with spicec.

Version-Release number of selected component (if applicable):
Always

How reproducible:
virt-viewer-0.5.2-1.el6.x86_64
spice-gtk-0.11-1.el6.x86_64
spice-xpi-2.7-11.el6.x86_64
spice-protocol-0.10.1-1.el6.noarch
spice-glib-0.11-1.el6.x86_64
spice-gtk-tools-0.11-1.el6.x86_64

Steps to Reproduce:
1. Connect to a multiple screens Windows guest with remote-viewer
2. Be sure mouse is grabbed inside guest in server mode
3. Try to move mouse between screens
  
Actual results:
Cursor is displayed on each of them - see screenshot

Expected results:
One cursor is dislayed

Additional info:
Comment 2 Marc-Andre Lureau 2012-03-19 15:19:16 EDT
patch proposed on the spice ML.
Comment 5 Marc-Andre Lureau 2012-04-20 09:23:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 7 errata-xmlrpc 2012-06-20 08:19:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html

Note You need to log in before you can comment on or make changes to this bug.