Bug 804325 - [abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000022 selinux_task_to_inode()
[abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 00000...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eric Paris
Fedora Extras Quality Assurance
abrt_hash:dcfa5f0bf8c86a8d2c3e94adc54...
:
: 811616 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 16:14 EDT by dan ginsberg
Modified: 2012-09-18 11:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 11:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dan ginsberg 2012-03-17 16:14:16 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.9-2.fc16.x86_64 root=/dev/mapper/VolGroup-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=VolGroup/lv_root rd.luks.uuid=luks-ea193c20-8b01-495a-b110-f8d68a6066ad LANG=en_US.UTF-8
kernel:         3.2.9-2.fc16.x86_64
reason:         BUG: unable to handle kernel NULL pointer dereference at 0000000000000022
time:           Sat 17 Mar 2012 12:54:54 PM PDT

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 0000000000000022
:IP: [<ffffffff8126825b>] selinux_task_to_inode+0x1b/0x30
:PGD a6dd2067 PUD a6db8067 PMD 0 
:Oops: 0002 [#1] SMP 
:CPU 1 
:Modules linked in: ath5k ath mac80211 cfg80211 tcp_lp ppdev parport_pc lp parport fuse lockd ip6t_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables arc4 i2c_i801 microcode joydev hp_wmi serio_raw sparse_keymap snd_hda_codec_hdmi snd_hda_codec_conexant iTCO_wdt iTCO_vendor_support snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm rfkill snd_timer snd soundcore snd_page_alloc r8169 mii uinput sunrpc xts gf128mul dm_crypt ums_realtek usb_storage wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: cfg80211]
:Pid: 3516, comm: pkill Not tainted 3.2.9-2.fc16.x86_64 #1 Hewlett-Packard Compaq Presario CQ60 Notebook PC/3612
:RIP: 0010:[<ffffffff8126825b>]  [<ffffffff8126825b>] selinux_task_to_inode+0x1b/0x30
:RSP: 0018:ffff8800a6d7fc68  EFLAGS: 00010286
:RAX: 0000000000000000 RBX: ffff88009f93c590 RCX: 0000000000000000
:RDX: 00000000000000e9 RSI: ffff8800af0535e0 RDI: ffff88009f93c590
:RBP: ffff8800a6d7fc68 R08: 0000000000000006 R09: ffff8800af077ab8
:R10: ffff8800af077a80 R11: 0000000000800000 R12: ffff8800af0535e0
:R13: ffff8800af077a80 R14: ffff8800a1768b40 R15: ffff8800af077a80
:FS:  00007f8e8caac700(0000) GS:ffff8800bb880000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 0000000000000022 CR3: 00000000a6ddf000 CR4: 00000000000406e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process pkill (pid: 3516, threadinfo ffff8800a6d7e000, task ffff8800902ac590)
:Stack:
: ffff8800a6d7fc78 ffffffff81265f36 ffff8800a6d7fcb8 ffffffff811de3e2
: 0000000000000000 ffff8800a6d7fde0 ffff8800a6d7fe48 ffff8800a6d7fde0
: ffff8800a6d7fe48 ffff8800a6d7fd70 ffff8800a6d7fd38 ffffffff81188276
:Call Trace:
: [<ffffffff81265f36>] security_task_to_inode+0x16/0x20
: [<ffffffff811de3e2>] pid_revalidate+0x92/0x100
: [<ffffffff81188276>] do_lookup+0x236/0x3a0
: [<ffffffff81186938>] ? inode_permission+0x48/0x100
: [<ffffffff8116662b>] ? kmem_cache_alloc_trace+0x10b/0x140
: [<ffffffff81189df0>] do_last+0xe0/0x8f0
: [<ffffffff8118a712>] path_openat+0xd2/0x3c0
: [<ffffffff8118ab22>] do_filp_open+0x42/0xa0
: [<ffffffff8119685f>] ? alloc_fd+0x4f/0x150
: [<ffffffff8117a3a7>] do_sys_open+0xf7/0x1d0
: [<ffffffff810ce4ba>] ? audit_syscall_entry+0x23a/0x350
: [<ffffffff8117a4a0>] sys_open+0x20/0x30
: [<ffffffff815ec682>] system_call_fastpath+0x16/0x1b
:Code: 5d 48 8b 40 68 8b 40 04 89 06 c3 0f 1f 44 00 00 55 48 89 e5 66 66 66 66 90 48 8b 97 48 04 00 00 48 8b 46 38 48 8b 52 68 8b 52 04 <c6> 40 22 01 89 50 1c 5d c3 66 66 66 2e 0f 1f 84 00 00 00 00 00 
:RIP  [<ffffffff8126825b>] selinux_task_to_inode+0x1b/0x30
: RSP <ffff8800a6d7fc68>
:CR2: 0000000000000022

comment:
:logged in as one use
:switch user to another account
:enter password and submit
:abrt popup ( followed by successfull log in ).
:
:not sure if at some point prior to all of this the laptop had gone to sleep

smolt_data:
:
:
:General
:=================================
:UUID: 423204aa-7873-4e2f-a297-c7438a1417e7
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3989.57
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core CPU       T4200  @ 2.00GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2000
:System Memory: 2943
:System Swap: 4991
:Vendor: Hewlett-Packard
:System: Compaq Presario CQ60 Notebook PC PCID
:Form factor: Notebook
:Kernel: 3.2.9-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10521:4156:13835) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(5772:28:4156:4986) pci, ath5k, ETHERNET, AR5BXB63 (Foxconn) 802.11bg Mini PCIe NIC
:(32902:10818:4156:13835) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4156:13835) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:4156:13835) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4156:13835) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(4332:33078:4156:13835) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10546:4156:13835) pci, None, NONE, 82801I (ICH9 Family) Thermal Subsystem
:(32902:10558:4156:13835) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10537:4156:13835) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10549:4156:13835) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10544:4156:13835) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:9288:4156:13835) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10548:4156:13835) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10551:4156:13835) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4156:13835) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(32902:10816:4156:13835) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10550:4156:13835) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10553:4156:13835) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10554:4156:13835) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4156:13835) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 13081819 11712604 11057244 3276800 3139530 3139530
:/dev/sda2 /boot ext4 1024 1024 508745 411055 385455 128016 127785 127785
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 24513411 23075395 21847824 6144000 6110502 6110502
:
Comment 1 Dave Jones 2012-03-19 10:33:10 EDT
if this was after a hibernate, it's possible that this may be memory corruption from the i915 driver. (We have a ton of bugs about that already).
Comment 2 Dave Jones 2012-04-11 10:52:01 EDT
*** Bug 811616 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2012-09-18 11:47:05 EDT
We've not seen this again since the i915 fix went in.  Closing this out.  If you see it again with 3.4.11 or 3.5.4 or newer, please let us know.

Note You need to log in before you can comment on or make changes to this bug.