Bug 804398 - egoboo has music that doesn't appear to be covered by the stated project license
egoboo has music that doesn't appear to be covered by the stated project license
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: egoboo-data (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal 799778
  Show dependency treegraph
 
Reported: 2012-03-18 12:21 EDT by Bruno Wolff III
Modified: 2012-08-07 15:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 15:57:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-03-18 12:21:44 EDT
Description of problem:
While working on 2.8.1 it was noticed that some of the sound files had copyright notices with all rights reserved which isn't the GPLv3.
It also looks like the music in 2.7.5 may have some questionable stuff, but mostly looks like it is free, though without a specific license stated.
Comment 1 Bruno Wolff III 2012-03-18 12:22:56 EDT
From bug 799778:
Martin Erik Werner 2012-03-15 13:24:11 CDT

Hmm, I think we may have another problem at our hands :(

$ for i in $(find -iname *.ogg); do ogginfo $i | grep right && echo $i; done
 Copyright=(c) 1999 Westwood Studios
./modules/cobolemperor.mod/objects/hostage.obj/sound5.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/soldier.mod/objects/evilforce.obj/sound0.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound2.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound1.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound0.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound13.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound16.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound11.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound14.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound17.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound12.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned5.mod/objects/demogorgon.obj/sound15.ogg
 Copyright=(c) 2004 PCB Productions
./modules/archmage.mod/objects/devildoor.obj/sound8.ogg
 Copyright=(c) 2004 PCB Productions
./modules/abyss2.mod/objects/devildoor.obj/sound8.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned3.mod/objects/layna.obj/sound2.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned3.mod/objects/layna.obj/sound1.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./modules/imprisoned3.mod/objects/layna.obj/sound3.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/monsters/vampyre.obj/sound2.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/monsters/vampyre.obj/sound1.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/monsters/vampyre.obj/sound3.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/monsters/vampyre.obj/sound10.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/monsters/vampyre.obj/sound9.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/monsters/vampyre.obj/sound8.ogg
 Copyright=(c) 1999 Westwood Studios
./basicdat/globalobjects/players/tourist.obj/sound5.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/misc/smithy.obj/sound0.ogg
 Copyright=A1 Free Sound Effects
./basicdat/globalobjects/unique/vorpalblade.obj/sound2.ogg
 Copyright message=(c) 2010 Sounddogs.com, All Rights Reserved
./basicdat/globalobjects/magic/glacialspike.obj/sound1.ogg
 Copyright message=Adam Frechette
./basicdat/music/Once_lost.ogg
 Copyright message=Adam Frechette
./basicdat/music/Irish_Night.ogg
 Copyright message=Adam Christopher Frechette
./basicdat/music/Safe_Haven.ogg

using ogginfo on separate files yields more info


IF we assume that those headers are correct (I do not know if all of them are,
the music ones should be though, see below), there's quite a bit of a problem.

It MIGHT be the case that they are incorrect and all sound effects are indeed
original content created by the Egoboo team, though I think that's unlikely...


The Westwoods studios stuff *may* be "freeware" at best.


The Sounddogs stuff is NOT ARReserved, but likely some sort of freeware (they
provide both gratis and paid sounds), encumbered by a EULA:
http://www.sounddogs.com/htm/licensemx.htm

Maybe the source isn't actually Sounddogs though, so maybe if the originals
were hunted down...?


Adam Frechette appears to be a composer which created free user content for
modding Newerwinter Nights, e.g:
http://nwvault.ign.com/View.php?view=Sounds.Detail&id=127

There is no mention of license anywhere, though as per
http://egoboo.sourceforge.net/phpBB3/viewtopic.php?f=4&t=548&p=40332#p40332
they are suppossedly "open content" (whatever that means).

That thread has some more info regarding music that might be relevant as well,
it would seem that there is a small set which is created by the Egoboo team, so
those pieces should be fine I'm guessing.


A large portion of the sound effects appears to be long-lost things which we're
unlikely to get license clarification for at all :(
Comment 2 Bruno Wolff III 2012-03-18 12:28:43 EDT
http://nwvault.ign.com/View.php?view=Sounds.Detail&id=492 indicates that "Hidden Danger" (and I would expect other of Adam Frechette's NWN stuff to be under similar terms) is free to use as long as credit is given. Credit appears to be given in the metadata for the sound files (at least in some cases), but I am not sure about all of them.
Comment 3 Bruno Wolff III 2012-03-18 13:25:26 EDT
I checked the ogg files (wav files aren't tagged) in current svn for egoboo-data and the all rights reserved tagged music is still there.
Comment 4 Tom "spot" Callaway 2012-03-19 10:04:56 EDT
So, as counter-intuitive as it sounds, "All Rights Reserved" usually doesn't mean anything. It's basically the legal equivalent of a no-op. :)

However, it does still leave us without clear licensing on all of those files. The Sounddogs EULA has distribution restrictions, so if those files are under those terms, they're not okay for Fedora.

I think we need to assume that the Copyright holders are as marked (and not egoboo generated), and that we have no permissions except where they are explicitly provided by those Copyright holders.

I know that's rather troublesome, but that's how we have to behave in situations like this. At a minimum, we should hopefully be able to reach out to Adam Frechette: http://adamfrechette.com/

The files owned by "Westwood Studios" are likely now owned by Electronic Arts. My advice would be to simply replace them, as I doubt they will be willing to give us acceptable licensing terms.

Last but not least, the PCB productions music looks like it came from here: http://www.pcbproductions.com/ , and I suspect they will also be uninterested in giving us acceptable licensing terms.
Comment 5 Tom "spot" Callaway 2012-07-27 14:37:34 EDT
Unless I see movement on this, I'm going to ask for egoboo-data to be blocked from Fedora.
Comment 6 Bruno Wolff III 2012-07-27 15:28:56 EDT
For f17, I ended up removing the updated version from updates-testing before it ever got to stable. Something definitely needs to be done before alpha freeze. I have been meaning to go back and see if the ego-boo project has cleaned things up. Even falling back in rawhide to the old version will still leave some questions. I'll at least take a look at what the current state of the upstream project is, and if things aren't good, then I look and see if there is a quick fix by dropping the questionable tracks until a more detailed look can be done.
Comment 7 Tom "spot" Callaway 2012-07-27 15:32:16 EDT
Thanks Bruno. Let me know if you need my help.
Comment 8 Bruno Wolff III 2012-07-28 12:44:48 EDT
I took a look at the music thread on their forums and it ended shortly after I had last looked. About all it did is confirm that a chunk of the music is non-free and that project participants overall, don't seem to have a good grasp of licensing.
The project is getting little development. What little is going on is being done on windows (though presumably an interested person could probably get the code working again on linux).
So I don't think we can count on upstream for helping fix the music situation.
About the only thing I would have time for before alpha would be to strip out all of the clearly questionable music/sounds and see if I can make it work without them in time.
Comment 9 Hans de Goede 2012-07-28 12:46:23 EDT
(In reply to comment #8)
> I took a look at the music thread on their forums and it ended shortly after
> I had last looked. About all it did is confirm that a chunk of the music is
> non-free and that project participants overall, don't seem to have a good
> grasp of licensing.
> The project is getting little development. What little is going on is being
> done on windows (though presumably an interested person could probably get
> the code working again on linux).
> So I don't think we can count on upstream for helping fix the music
> situation.
> About the only thing I would have time for before alpha would be to strip
> out all of the clearly questionable music/sounds and see if I can make it
> work without them in time.

As the guy who originally packaged it, my 2 cents are that it is not worth the effort, lets simply drop it.
Comment 10 Bruno Wolff III 2012-07-28 12:50:41 EDT
One other note is that nothing has happened in Debian for the bug filed there about the music licensing issue. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=664126)
Comment 11 Bruno Wolff III 2012-07-28 12:53:42 EDT
While I hate to see games dropped, I am willing to go along with Hans on this one.
While egoboo seems to have some neat ideas, the game really needs work (for playability, not just licensing) and it isn't likely to get it in the foreseeable future. I'd rather see our limited resources used on games that are either playable as is, or have a future.
Comment 12 Bruno Wolff III 2012-08-07 15:57:29 EDT
egoboo has been retired in f18/devel.

Note You need to log in before you can comment on or make changes to this bug.