Bug 80442 - IBM ThinkPad A30P Blank Display and Failed Media Check
IBM ThinkPad A30P Blank Display and Failed Media Check
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-26 11:09 EST by Mike Kuhnkey
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 09:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Kuhnkey 2002-12-26 11:09:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Bad: IBM ThinkPad A30p LCD blanks on graphical install.
Bad: IBM ThinkPad A30p LCD blanks on text install
Bad: IBM ThinkPad A30p LCD blanks following "linux acpi=off"

Good: IBM ThinkPad A30p Toggling between external and internal display (using
Fn-F7) resets display.
Good: IBM ThinkPad A30p works well with psyche.

Bad: IBM ThinkPad A30p reports failed mediacheck for phoebe*.iso
Good: Failed media on IBM ThinkPad A30p passes on Compaq Presario 5838.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Download phoebe*.iso: Verify MD5
Create CD set using command-line:
"cdrecord -v -eject speed=1 dev=0,0,0 <filename.iso>"

1.Select CD-Rom as Boot Device on IBM ThinkPad A30p during POST.
2.Select any mode of installation (Graphical,Text...)
3.Observe boot-loader output..followed by blank LCD Display.
4.Toggle internal=>external=>internal (Fn-F7...Fn-F7).
5.Observe "mediacheck" for boot CD-Rom.
6.Perform "mediacheck" for boot CD-Rom.
7.Observe "failed" media results.
8.(Power-Down)
9.Transfer CD-Rom to Compaq Presario 5838.
10. Boot CD-Rom
11. Perform "mediacheck"
12. Observe "PASS" media results.
13. Three-disk-set (phoebe) successfully installed on Compaq.


Actual Results:  Did NOT install phoebe due to "FAILED" media check on IBM
ThinkPad A30p.

Did install phoebe on Compaq Presario 5838 with "PASSED" media.

Additional Note:
RedHat "psyche" was installed via FTP on (same) IBM ThinkPad A30p but only after
disk1 "PASSED" but disk2 and disk3 failed.

Additional info:
Comment 1 Robert de Rooy 2002-12-26 16:49:37 EST
I encountered the same screen blanking problem on my ThinkPad T30 during 
installation.

In addition I have the same problem with RH8.0 during normal operation. I 
can 'fix' it by putting the machine into suspend by pressing the suspend key 
or closing the lid and bringing it back again (display cycle with Fn-F7 does 
not work on the T30).
But this does not work during phoebe installation. Instead I had to keep 
moving the mouse during installation to prevent the screen blanking from 
occuring.

The screen blanking is not a problem with normal operation after install on 
phoebe.

I suspect it only happens with APM enabled, and phoebe uses ACPI. So I guess 
that the phoebe redhat-boot kernel used during install has APM.
Comment 2 Robert de Rooy 2002-12-26 17:34:08 EST
Some more information.

I have encountered this screen blanking problem with several generations 
ThinkPad's (at least the T20, T21 and T30) and a host of Red Hat Linux 
releases. But generally it has not been a problem during installation, but 
rather after install is done in either text or graphical mode.

What happens is that if your not in ACPI mode that if you don't use the 
keyboard/mouse for a while is that the machine blanks the LCD (black screen) 
and turns off the LCD backlight. When you then press a key/move the mouse it 
turns the LCD backlight back on, but the display remains black.
In most cases forcing a display refresh by putting the machine into suspend 
and bringing it back clears things up, but not always.

You might try to start the install with apm=off as a kernel boot option.
Comment 3 Mike Kuhnkey 2002-12-26 20:05:02 EST
Tried "linux apm=off" (No Joy)...I too have experienced 'screen flicker' and
'loss-of-backlight' on the A30p but with BIOS upgrade from IBM site and move to
newer XFree86 (psyche) the effects were significantly reduced. The A30p
sometimes   fails to respond if left on overnight.

F.W.I.W: Hardware accelerated X works well on the ATI Mobility RADEON M6 with
psyche..but I lost sound for 'TuxRacer' (worked on 7.3..Valhalla...but desktop
sounds continue to function)
Comment 4 Robert de Rooy 2002-12-26 22:35:25 EST
I have never had a 'loss of backlight', rather the contrary. backlight is the
only thing that comes back on after the the screen blanks and I press a key.
I have seen screen flicker, but that only happens when I use an AC adapter not
meant for the ThinkPad (Amp rating to low) in combination with a drained
battery, so it has problems getting enough power out of the AC adapter.
Comment 5 Mike A. Harris 2002-12-30 01:35:30 EST
>Bad: IBM ThinkPad A30p LCD blanks on graphical install.
>Bad: IBM ThinkPad A30p LCD blanks on text install
>Bad: IBM ThinkPad A30p LCD blanks following "linux acpi=off"

If this occurs with or without XFree86 involved, then I am inclined to
believe it is not an XFree86 related problem at all.  More likely it is
APM/ACPI/weirdo hardware issue, or a kernel issue with APM or somesuch.

>I have encountered this screen blanking problem with several generations 
>ThinkPad's (at least the T20, T21 and T30) and a host of Red Hat Linux 
>releases. But generally it has not been a problem during installation, but 
>rather after install is done in either text or graphical mode.

Again, if it occurs when XFree86 is not even part of the picture, then that
implies it is not an XFree86 problem, but is a hardware/kernel/apm/acpi
issue of some kind.

Reassigning to kernel component.

Comment 6 Robert de Rooy 2003-01-21 20:58:29 EST
I just installed Phoebe2 (8.0.93) where ACPI is no longer enabled.
It still has the same screen blanking problem as the first public beta during 
install.
But now the problem is also back after install (like in RH8.0 and before) due 
to the fact that ACPI is disabled ;-((
Comment 7 Robert de Rooy 2003-01-23 22:32:07 EST
I spoke to someone at EmperorLinux at LinuxWorld (they resell laptops with 
Linux installed, including the T30).
I was told to go into the BIOS and disable Screen Blanking to resolve the 
issue.
I found the option under 'Config' -> 'Power' and it did indeed solve the 
screen blanking problem!.
Comment 8 Mike A. Harris 2003-01-24 01:53:24 EST
Ahh..  so I was right.  ;o)  It is an APM/ACPI/BIOS/weirdo problem that
is hardware specific.  ;o)
Comment 9 Alan Cox 2003-06-09 09:35:55 EDT
BIOS issue confirmed. Closing
Comment 10 Robert de Rooy 2003-06-09 10:46:44 EDT
Actually, I suspect (untested by me) that the following patch which was 
recently included in 2.5 bitkeeper fixes the issue

http://linux.bkbits.net:8080/linux-2.5/cset@1.1243.52.9?
nav=index.html|ChangeSet@-7d

From: Samuel Thibault <Samuel.Thibault@ens-lyon.fr>

Some fixes for console blanking: on some laptops, doing VESA blanking after
the bios did an apm blanking because of a screen closure thrashes the
recovery (the video board doesn't seem to have synchronisation registers
correctly initialized, since the LCD panel progressively turns white, maybe
damaging it ?).

I hence moved the schedule for vesa powerdown after the apm blank hook
call, so that if it succeeds, it won't be called.  I also moved the apm
unblank & palette restoration after the vesa unblank, to have a more lifo
scheme (also required, or the screen remains black).

Btw, why del_timer_sync was called twice in timer_do_blank_screen when
vesa_off_interval==0 ?

--- 1.45/drivers/char/vt.c	Wed May  7 23:26:53 2003
+++ 1.46/drivers/char/vt.c	Thu Jun  5 23:36:44 2003
@@ -2712,14 +2712,7 @@
 	hide_cursor(currcons);
 	if (!from_timer_handler)
 		del_timer_sync(&console_timer);
-	if (vesa_off_interval) {
-		console_timer.function = vesa_powerdown_screen;
-		mod_timer(&console_timer, jiffies + vesa_off_interval);
-	} else {
-		if (!from_timer_handler)
-			del_timer_sync(&console_timer);
-		console_timer.function = unblank_screen_t;
-	}
+	console_timer.function = unblank_screen_t;
 
 	save_screen(currcons);
 	/* In case we need to reset origin, blanking hook returns 1 */
@@ -2730,6 +2723,12 @@
 
 	if (console_blank_hook && console_blank_hook(1))
 		return;
+
+	if (vesa_off_interval) {
+		console_timer.function = vesa_powerdown_screen;
+		mod_timer(&console_timer, jiffies + vesa_off_interval);
+	}
+
     	if (vesa_blank_mode)
 		sw->con_blank(vc_cons[currcons].d, vesa_blank_mode + 1);
 }
@@ -2771,12 +2770,12 @@
 	}
 
 	console_blanked = 0;
-	if (console_blank_hook)
-		console_blank_hook(0);
-	set_palette(currcons);
 	if (sw->con_blank(vc_cons[currcons].d, 0))
 		/* Low-level driver cannot restore -> do it ourselves */
 		update_screen(fg_console);
+	if (console_blank_hook)
+		console_blank_hook(0);
+	set_palette(currcons);
 	set_cursor(fg_console);
 }

Note You need to log in before you can comment on or make changes to this bug.