Bug 804437 - [abrt] libreoffice-core-3.5.1.2-1.fc17: oosplash rtl_uString_release(NULL) SIGSEGV upon failing osl_getProcessWorkingDir
[abrt] libreoffice-core-3.5.1.2-1.fc17: oosplash rtl_uString_release(NULL) SI...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
abrt_hash:56852f8eb29b220deb70b6b185f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 15:25 EDT by admin
Modified: 2012-03-20 06:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 06:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (2.24 KB, text/plain)
2012-03-18 15:25 EDT, admin
no flags Details
File: coredump (9.12 MB, text/plain)
2012-03-18 15:26 EDT, admin
no flags Details
File: smolt_data (2.94 KB, text/plain)
2012-03-18 15:27 EDT, admin
no flags Details
File: maps (7.20 KB, text/plain)
2012-03-18 15:27 EDT, admin
no flags Details
File: backtrace (5.26 KB, text/plain)
2012-03-18 15:27 EDT, admin
no flags Details

  None (edit)
Description admin 2012-03-18 15:25:39 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/oosplash --writer /tmp/kde-raistlin/ark4M3zY8//3-45.doc
comment:        Open file, which was deleted by other software (long office initialisation).
crash_function: rtl_uString_release
executable:     /usr/lib64/libreoffice/program/oosplash
kernel:         3.3.0-0.rc7.git0.2.fc17.x86_64
pid:            7587
pwd:            /tmp/kde-raistlin/ark4M3zY8 (deleted)
reason:         Process /usr/lib64/libreoffice/program/oosplash was killed by signal 11 (SIGSEGV)
time:           Пн. 19 марта 2012 02:06:47
uid:            1000
username:       raistlin
xsession_errors: 

backtrace:      Text file, 5389 bytes
event_log:      Binary file, 2294 bytes
maps:           Text file, 7372 bytes
smolt_data:     Binary file, 3008 bytes

dso_list:
:/usr/lib64/libXinerama.so.1.0.0 libXinerama-1.1.2-1.fc17.x86_64 (Fedora Project) 1331877185
:/usr/lib64/libz.so.1.2.5 zlib-1.2.5-6.fc17.x86_64 (Fedora Project) 1330093961
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.8-2.fc17.x86_64 (Fedora Project) 1330102414
:/usr/lib/locale/locale-archive glibc-common-2.15-28.fc17.x86_64 (Fedora Project) 1331877125
:/usr/lib64/libnss_files-2.15.so glibc-2.15-28.fc17.x86_64 (Fedora Project) 1331877139
:/usr/lib64/libm-2.15.so glibc-2.15-28.fc17.x86_64 (Fedora Project) 1331877139
:/usr/lib64/libreoffice/ure/lib/libuno_sal.so.3 libreoffice-ure-1:3.5.1.2-1.fc17.x86_64 (Fedora Project) 1331878874
:/usr/lib64/libreoffice/program/oosplash libreoffice-core-1:3.5.1.2-1.fc17.x86_64 (Fedora Project) 1331878928
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.99.1-3.fc17.x86_64 (Fedora Project) 1330102415
:/usr/lib64/libgcc_s-4.7.0-20120315.so.1 libgcc-4.7.0-0.20.fc17.x86_64 (Fedora Project) 1332018538
:/usr/lib64/libpng15.so.15.9.0 libpng-2:1.5.9-1.fc17.x86_64 (Fedora Project) 1331540280
:/usr/lib64/libstdc++.so.6.0.17 libstdc++-4.7.0-0.20.fc17.x86_64 (Fedora Project) 1332018548
:/usr/lib64/ld-2.15.so glibc-2.15-28.fc17.x86_64 (Fedora Project) 1331877139
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-3.fc17.x86_64 (Fedora Project) 1330102413
:/usr/lib64/libdl-2.15.so glibc-2.15-28.fc17.x86_64 (Fedora Project) 1331877139
:/usr/lib64/libXext.so.6.4.0 libXext-1.3.1-1.fc17.x86_64 (Fedora Project) 1331877149
:/usr/lib64/libc-2.15.so glibc-2.15-28.fc17.x86_64 (Fedora Project) 1331877139
:/usr/lib64/libpthread-2.15.so glibc-2.15-28.fc17.x86_64 (Fedora Project) 1331877139

environ:
:XDG_VTNR=1
:XSUNTRANSPORT=shmem
:ORBIT_SOCKETDIR=/tmp/orbit-raistlin
:SSH_AGENT_PID=876
:XDG_SESSION_ID=1
:KDE_MULTIHEAD=false
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=raistlin.hostace.ru
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=7577
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=raistlin.hostace.ru;1332097606;39558;7577_TIME37904660
:XDM_MANAGED=method=classic
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/raistlin/.gtkrc-2.0:/home/raistlin/.gtkrc-2.0-kde4:/home/raistlin/.kde/share/config/gtkrc-2.0
:XRE_PROFILE_NAME=
:GS_LIB=
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/raistlin/.gtkrc:/home/raistlin/.kde/share/config/gtkrc
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-KfkPab
:KDE_FULL_SESSION=true
:MOZILLA_FIVE_HOME=/usr/lib64/firefox
:'IMSETTINGS_MODULE=X compose table'
:USER=raistlin
:XRE_PROFILE_LOCAL_PATH=
:LD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox/plugins:/usr/lib64/firefox
:XCURSOR_SIZE=0
:XRE_START_OFFLINE=
:SSH_AUTH_SOCK=/tmp/ssh-grDiSgDWa730/agent.730
:LIBPATH=/usr/lib64/firefox:/usr/lib64/firefox
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/962,unix/unix:/tmp/.ICE-unix/962
:GNOME_DISABLE_CRASH_DIALOG=1
:MOZ_APP_LAUNCHER=/usr/bin/firefox
:MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins:/usr/lib64/firefox/plugins
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/kde4/ark.desktop
:DESKTOP_SESSION=kde-plasma
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/raistlin/.local/bin:/home/raistlin/bin
:MAIL=/var/spool/mail/raistlin
:FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox/res/Xft
:QT_IM_MODULE=xim
:PWD=/tmp/kde-raistlin/ark4M3zY8
:XMODIFIERS=@im=none
:KDE_SESSION_UID=1000
:GNOME_KEYRING_PID=728
:LANG=ru_RU.UTF-8
:KDE_IS_PRELINKED=1
:XRE_PROFILE_PATH=
:KDEDIRS=/usr
:XSUNSMESIZE=512
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/raistlin
:KDE_SESSION_VERSION=4
:LANGUAGE=
:XCURSOR_THEME=Xeonyx
:SAL_ENABLE_FILE_LOCKING=1
:DYLD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:LOGNAME=raistlin
:CVS_RSH=ssh
:MOZ_GRE_CONF=/etc/gre.d/gre64.conf
:MOZ_LAUNCHED_CHILD=
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-YhNjJO1PoH,guid=1c737bb244514c2f5f70e53f00000037
:NO_EM_RESTART=
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:SHLIB_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:MOZ_CRASHREPORTER_RESTART_ARG_1=
:WINDOWPATH=1
:MOZ_CRASHREPORTER_RESTART_ARG_0=/usr/lib64/firefox/firefox
:XRE_BINARY_PATH=
:XDG_RUNTIME_DIR=/run/user/raistlin
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/raistlin/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=xim
:'MOZ_CRASHREPORTER_DATA_DIRECTORY=/home/raistlin/.mozilla/firefox/Crash Reports'
:XUL_APP_FILE=
:NO_AT_BRIDGE=1
:XAUTHORITY=/tmp/kde-raistlin/xauth-1000-_0

var_log_messages:
:Mar 19 02:06:47 raistlin kernel: [37906.103300] oosplash[7587]: segfault at 0 ip 000000381142cac1 sp 00007fff43a52ca0 error 4 in libuno_sal.so.3[3811400000+57000]
:Mar 19 02:06:47 raistlin abrt[7596]: Saved core dump of pid 7587 (/usr/lib64/libreoffice/program/oosplash) to /var/spool/abrt/ccpp-2012-03-19-02:06:47-7587 (9560064 bytes)
Comment 1 admin 2012-03-18 15:25:45 EDT
Created attachment 570937 [details]
File: event_log
Comment 2 admin 2012-03-18 15:26:58 EDT
Created attachment 570938 [details]
File: coredump
Comment 3 admin 2012-03-18 15:27:03 EDT
Created attachment 570939 [details]
File: smolt_data
Comment 4 admin 2012-03-18 15:27:06 EDT
Created attachment 570940 [details]
File: maps
Comment 5 admin 2012-03-18 15:27:09 EDT
Created attachment 570941 [details]
File: backtrace
Comment 6 Stephan Bergmann 2012-03-20 06:43:06 EDT
This is due to the current working directory having been unlinked (see "pwd: /tmp/kde-raistlin/ark4M3zY8 (deleted)" in comment 0).  Upstream <http://cgit.freedesktop.org/libreoffice/core/commit/?id=7b9ea611bea133e758302b99df339439919101ed> "Resolves rhbz#804437, do not rtl_uString_release(NULL)" fixes that towards LibreOffice 3.6.  However, LibreOffice is not really functional when osl_getProcessWorkingDir fails, likely failing with uncaught C++ exceptions later on, so I see little point in backporting that fix to Fedora-17's LibreOffice 3.5.1 now.

Note You need to log in before you can comment on or make changes to this bug.