Bug 804446 - cannot fresh install from DVD
cannot fresh install from DVD
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-18 16:32 EDT by John Reiser
Modified: 2012-04-01 23:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 13:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/anaconda.log (16.47 KB, text/plain)
2012-03-18 16:32 EDT, John Reiser
no flags Details
/tmp/storage.log (923.41 KB, text/plain)
2012-03-18 16:33 EDT, John Reiser
no flags Details
/tmp/syslog (106.09 KB, text/plain)
2012-03-18 16:33 EDT, John Reiser
no flags Details
/tmp/storage.log (UFD install media) (120.09 KB, text/plain)
2012-04-01 13:00 EDT, Marcos Mello
no flags Details

  None (edit)
Description John Reiser 2012-03-18 16:32:47 EDT
Created attachment 570954 [details]
/tmp/anaconda.log

Description of problem: Fresh install from DVD fails because the DVD is not recognized as being an install DVD (with repo and packages, etc.)


Version-Release number of selected component (if applicable):
anaconda-17.13-1.fc17.x86_64
lorax-17.10-1.fc17.x86_64

How reproducible: every time


Steps to Reproduce:
1. Build and burn an install DVD for Fedora 17-branched using pungi and lorax-17.10-1.fc1 and anaconda-17.13-1.fc17.
2. Boot the DVD for fresh install on Basic disks, intending to use the DVD repo only.
3. Accept/choose defaults.
  
Actual results: If no network, then the installer quits with error dialog "No Network Available." If network is available, then the installer offers only network repos (Fedora, Fedora Test Updates, Fedora Updates) and no DVD repo.


Expected results: Ability and preference to use the DVD repo.


Additional info:
Comment 1 John Reiser 2012-03-18 16:33:21 EDT
Created attachment 570955 [details]
/tmp/storage.log
Comment 2 John Reiser 2012-03-18 16:33:46 EDT
Created attachment 570956 [details]
/tmp/syslog
Comment 3 John Reiser 2012-03-18 16:37:11 EDT
The volume label on the DVD (visible on desktop icon, etc.) is "Fedora 17 x86_64".
Comment 4 John Reiser 2012-03-18 17:21:55 EDT
Proceeding all the way to the repo selection screen: click on "Add additional software repositories", choose Repository type CD/DVD, give the repo a name, and click OK.  This fails with "No Media Found: No installation media was found.  Please insert a disk into your drive and try again."  However, the tray is locked (contains the install DVD that was booted, and is the live backup to the active squashfs root), so I cannot remove and re-insert the install DVD in order to try again.  Fail!

Also, the boot command line option "askmethod" is ignored silently.
Comment 5 John Reiser 2012-03-18 17:48:49 EDT
Switching to VT2, the DVD can be mounted:
   # mkdir /foo
   # mount -o ro,loop /dev/sr0 /foo
   # cd /foo; ls
     <usual files for install DVD: EFI, GPL, LiveOS, Packages, ...>
So wny is "no installation media found"?

Choosing HTTP/FTP repository with URL: file:///foo [after mounting as above] fails because it demands http: or ftp: protocol.

Selecting an NFS repo of localhost:/foo fails with timeout.  [Somewhat expected, I didn't setup any exports, etc.]

The choice of a harddrive repo (a tree in some other partition) is not available.  The choice of a harddrive .iso is not available.
Comment 6 John Reiser 2012-03-18 20:29:08 EDT
I encounter the same problems using Fedora-17-Beta-TC2-x86_64-DVD.iso that was announced today by Andre Robatino; so it isn't just the .iso that I composed that has problems.

I proposed this bug as a blocker bug for Fedora 17 Beta because the Fedora 17 Alpha criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options" is not met, and the Beta criteria include all the Alpha criteria ("All Fedora 17 Alpha Release Criteria must be met").
Comment 7 Andre Robatino 2012-03-18 20:41:41 EDT
I see this with both the i386 and x86_64 17 Beta TC2 DVDs. Am pretty sure it did not happen with TC1.
Comment 8 Chris Lumens 2012-03-18 22:43:48 EDT
There's no ID_FS_TYPE for your DVD drive, which you can see in the storage.log.  I don't yet know whether this is due to a change in udev or anaconda though.
Comment 9 Adam Williamson 2012-03-19 03:48:28 EDT
Andre and Chris Murphy both report having reproduced this, it seems like a general issue.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Chris Murphy 2012-03-19 04:00:54 EDT
Definitely does not happen with TC1, does with TC2. Seems to me one issue is Updates and Test Updates repos are enabled by default for whatever reason, which was not the case with TC1. 

With TC1, if I checked either option, a small dialog to configure network settings comes up, then it downloads repo info. With TC2 the network configuration happens on its own, I don't get a dialog.

If I disable Updates and Test Updates, then proceed, it takes ~10 minutes of downloading during 'starting installation' and then the install process itself intermittently is fast with DVD access, and slow with internet downloading - with a pretty significant percentage of it downloaded despite these repos disabled.
Comment 11 Adam Williamson 2012-03-19 11:05:01 EDT
Chris: that's not an issue, it's a consequence. anaconda knows whether it has packages available on the installation media or not. If it doesn't, it automatically tries to use remote repositories.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2012-03-19 17:25:33 EDT
Discussed at 2012-03-19 QA meeting, acting as a blocker review meeting. Accepted as a blocker per Alpha criterion "When booting from a DVD ISO image, the installer must be able to use the DVD local package source options".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Will Woods 2012-03-19 21:13:02 EDT
Should be fixed by anaconda commit:
  37144b9 dracut: use /run/install/source for repodir

And an upstream dracut patch:
  http://article.gmane.org/gmane.linux.kernel.initramfs/2555
Comment 14 John Reiser 2012-03-21 12:30:09 EDT
Tested good using these patches that were posted to [anaconda-devel-list],
starting from anaconda-17.13-1.fc17.x86_64:
   use mount --rbind to move submounts under /run into $NEWROOT    {dracut}
   read args from 80kickstart.conf
   use /run/install/source for repodir
   dracut: accept inst.updates or updates for live.updates
   add symlink from /mnt/install -> /run/install           {lorax}
   fix nfsiso:...:/path/to/filename.iso (#804515)
   dracut startup: "Loading $product $version $arch installer..."
   Default to text-mode if 'console=XXX' was provided (#804506)
   fix text mode KeyError crash (#804483)

The patch
   makeupdates: add support for updating systemd services/targets
did not apply cleanly, so I guessed at a fixup.  Besides, I wasn't going to use makeupdates until after the official package upgrade.
Comment 15 Fedora Update System 2012-03-23 01:18:21 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 16 John Reiser 2012-03-23 12:49:00 EDT
I performed a successful fresh install from DVD, using a DVD made by pungi with:
   anaconda-17.14-1.fc17.x86_64
   anaconda-dracut-17.14-1.fc17.noarch
   dracut-017-43.git20120312.fc17.noarch
   lorax-17.12-1.fc17.x86_64
Comment 17 John Reiser 2012-03-23 12:50:42 EDT
That was
   dracut-017-62.git20120322.fc17.noarch
not the -43 version.
Comment 18 Fedora Update System 2012-03-23 13:10:27 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-03-23 13:45:43 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Andre Robatino 2012-03-23 18:58:37 EDT
Confirmed fixed in RC1. For both i386 and x86_64 DVDs, the Installation Repo is available, enabled by default, and used during installation. The other 3 repos are disabled by default.
Comment 21 Marcos Mello 2012-04-01 12:52:35 EDT
This bug is not fixed when you transfer the DVD media to a USB Flash Disk using dd.

The "Installation Repo" is not available in Beta-RC2 x86-64 DVD using this method. Anaconda depends on the network to perform the installation.
Comment 22 Marcos Mello 2012-04-01 13:00:09 EDT
Created attachment 574353 [details]
/tmp/storage.log (UFD install media)
Comment 23 Adam Williamson 2012-04-01 21:24:19 EDT
Marcos: that's nothing new and it's not really a bug. It's just an inherent limitation of dd'ing the image. It's been the case for several releases.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Chris Murphy 2012-04-01 23:37:29 EDT
I'd suggest changes to the Fedora installation guide. I implies dd, Live Creator, and livecd-tools will all do the job. Further the names Live Creator and livecd-tools, imply they are only for Live CD ISOs, leaving only dd for the DVD, even though this isn't stated. So if dd isn't expected to work I think documentation needs to be updated... I find the 3.2.2 section of the Installation Guide confusing.

Note You need to log in before you can comment on or make changes to this bug.