Bug 80445 - radeon driver seems not to work and make the screen a real mess.
radeon driver seems not to work and make the screen a real mess.
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
Blocks: 79579 82776
  Show dependency treegraph
Reported: 2002-12-26 13:08 EST by Dams
Modified: 2007-04-18 12:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-08 06:03:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The XF86Config.test anaconda generated (3.91 KB, text/plain)
2002-12-26 13:10 EST, Dams
no flags Details
anaconda.log (4.00 KB, text/plain)
2002-12-26 13:11 EST, Dams
no flags Details

  None (edit)
Description Dams 2002-12-26 13:08:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
During the installation process, when anaconda start X, the monitor turns off
during 3-4 seconds and after, when X comes, i cannot distinguish anything. Even
the consoles become unreadable after X is started. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot on the phoebe cd.
2. press enter at the 'boot:' prompt. 
3. Skip the mediacheck (or do it).
4. wait for X to come.

Actual Results:  First the screen seems to poweroff. After 4-5 seconds X comes.
Graphical anaconda seems to run and the mouse move. But the display become
unclear and i hardly distinguish things in it. The mouse cursor is like a big
square but is like the rest of the screen : a real mess.

Expected Results:  I should see the display correctly.

Additional info:

My eyes works perfectly. :)
I did not complete the installation process.
The 1st phoebe cd passed succesfully the mediacheck test.
Hardware is :
Video Card : 01:05.0 VGA compatible controller: ATI Technologies Inc Radeon R100
QD [Radeon 64 DDR]
Motherboard : Asus a7m266-d (dual athlon)
Monitor : Mitsubishi Diamond Plus 230SB
Comment 1 Dams 2002-12-26 13:10:06 EST
Created attachment 88913 [details]
The XF86Config.test anaconda generated
Comment 2 Dams 2002-12-26 13:11:06 EST
Created attachment 88914 [details]
Comment 3 Mike A. Harris 2002-12-26 16:56:56 EST
If you do a text mode install, and run redhat-config-xfree86 afterward,
does X work correctly?
Comment 4 Dams 2002-12-26 18:13:09 EST
I've just done a text install. During the "firstboot" program, X was in the same
state. When I ran "redhat-config-xfree86", the problem was still present and i
wasnt able to click on anything as i cannot distinguish buttons and all..
Comment 5 Dadao WANG 2002-12-29 13:10:28 EST
I've a ATI radeon 8500 card, I can install phoebe without any problem. But after
I've logged in, if I move for example a terminal window with mouse or even type
something under the terminal, or move any other window, I can see that some area
on my monitor will have some   flickers. The same setting under redhat 8.0 works

My monitor is a SAMSUNG SyncMaster 171s (LCD).  
Comment 6 Dams 2002-12-29 13:14:36 EST
I dont think the bug is the same as i got a radeon 7000 and it's not the same
chip than radeon 8500... 
Comment 7 Nils Philippsen 2003-01-01 06:44:11 EST
It's the same here with my OEM Radeon 7500: upgraded to the beta XFree86
packages, the display is garbled(*), switching back to text mode only every
other character gets displayed.

(*): every other about 20 pixels get displayed or not ("X"=pixel gets displayed,

Comment 8 Antonio Sanna 2003-01-01 07:50:52 EST
I have the same problem with Radeon 32 MB.
Moreover, when I try a text installation the PC freezes and I must
Comment 9 Chris Boyle 2003-01-02 15:10:24 EST
I'm gettiing the same problem on 8.0. I've also tried redhat-config-xfree86 and 
X completely crashes stating "FATAL ERROR: X server reset by peer". That was 
run from linux rescue mode from the boot CD though as if I boot normal my 
system freezes on X and I can't switch to text mode.
Comment 10 Nils Philippsen 2003-01-09 05:58:43 EST
Guys, please attach some more info on the cards you're using in case you haven't
done it:

- "lspci -v" output
- exact manufacturer/model of the card
- whether you use a CRT or LCD monitor

Here's mine:

"lspci -v":
--- 8< ---
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV200 QW [Radeon
7500] (prog-if 00 [VGA])
        Subsystem: Unknown device 1787:2709
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 32, IRQ 12
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c000 [size=256]
        Memory at e1000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
--- >8 ---

The card is an OEM "Xelo Radeon 7500", the monitor is a NEC MultiSync XP17 CRT
attached via a DVI/VGA adapter to the DVI port of the card (so I could my VGA/TV
sync converter box to the VGA port).

Mike also asked me to ask you to check whether there are BIOS updates for your
cards available either from ATI or the respective manufacturer.
Comment 11 Dams 2003-01-09 09:29:04 EST
lspci -v :

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD [Radeon
64 DDR] (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc Radeon 7000/Radeon
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64, IRQ 16
        Memory at f4000000 (32-bit, prefetchable) [size=64M]
        I/O ports at d800 [size=256]
        Memory at f2000000 (32-bit, non-prefetchable) [size=512K]
        Expansion ROM at f3fe0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

The card is an OEM Radeon 7000 and i dont know the manufacturer. 
Should it be writen on the card ? (i'll check)
My monitor is Mitsubishi Diamond Plus 230SB CRT
Comment 12 Mike A. Harris 2003-01-09 20:20:16 EST
That is most definitely not a Radeon 7000.  The Subsystem says it is, but
I say it is not.  The subsystem info is wrong.

Radeon QD is an original Radeon.  It was rebranded later as the Radeon 7200,
but they were not widely spread as such.  The Radeon 7000 is a rebranded
Radeon VE, which is ATI's RV100 chip (not R100).

Basically the PCI ID data on sourceforge is on crack.  I'll have to hack
at it with a hacksaw one of these days.
Comment 13 Antonio Sanna 2003-01-10 03:44:55 EST
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R100 QD [Radeon
64 DDR] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc Radeon 7000/Radeon
	Flags: bus master, stepping, 66Mhz, medium devsel, latency 32, IRQ 10
	Memory at d4000000 (32-bit, prefetchable) [size=64M]
	I/O ports at d000 [size=256]
	Memory at d9000000 (32-bit, non-prefetchable) [size=512K]
	Expansion ROM at <unassigned> [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

Radeon 32 MB
Monitor CRT Philips 107S
Comment 14 Mike A. Harris 2003-01-24 01:29:21 EST
I think there is a bit of a communication failure, so let me clarify
things a bit.

The original ATI Radeon, is an "ATI Radeon QD".  The "QD" part, is the
ASCII representation of the ATI device ID, which is common ATI nomenclature
for their individual chips inside a given family.  The hexadecimal
representation of "QD" is 0x5144.  This chip is part of what is known as
the ATI "R100" family.  Other chips include QE, QF, QG.

The second chip family was the "ATI Radeon VE", which was a lower priced
"Value Edition".  The "VE" is part of the product name, rather than part
of the actual chip part number.  This chip is a member of the "RV100" family.
The "Radeon VE" has a few features removed from it compared to the R100 chip
family, in particular the TCL unit is gone.  It is also the first chip which
was marketed as a dualhead card.

ATI's next generation of chips included the Radeon 7500 (RV200) and the
Radeon 8500 (R200).  When these chips came to market, ATI remarketed
their original 2 chipset families (R100 and RV100) under new names.  The
original Radeon became known as the "Radeon 7200" and the "Radeon VE" was
renamed to "Radeon 7000".  The actual chip itself is identical, the only
difference being the name printed on the box.

So, as I stated above, your lspci output clearly shows the card as an
ATI Radeon QD, which is an original Radeon, now known as the Radeon 7200.

The information appearing on the second line labeled "Subsystem" which
states "Radeon 7000/Radeon" is incorrect information.  This indicates
that the "pcitable" file on the system contains incorrect information in

Comment 15 Antonio Sanna 2003-01-24 09:49:01 EST
I cant' install even beta 2!
I have seen that Mandrake Users have similar problems: there is a hope or I have
to come back tu Windows?
Comment 16 Mike A. Harris 2003-01-24 10:40:09 EST
Making false threats that you'll go back to Windows if this is not fixed
does not in any way lend itself to be conducive to helping solve this

The bug is reported, and there are 200 other ones reported too.  There is
not 200 engineers, each working on one bug in parallel however.  There is
one engineer working on one bug at a time.  The more highly detailed the
report, and more likely a problem is to be reproduceable and/or resolveable,
the higher the report makes it in the "this weeks bugs to hit with a
debugger" queue.  Those that do not, might make next weeks queue, or the
week after.  Or they may remain there until upstream fixes the problem,
someone submits a patch, or some other resolution.

If you are unable to beta test the software patiently and provide
constructive information in the bug reports, then your help in finding
the solution and testing it is not requested.  Bugzilla is NOT an end
user help forum or tech support forum.  It is _strictly_ a bug tracker,
and information gatherer.  The bug has been reported, and some information
has been gathered, some points clarified.

Now, you all wait until there is something further I must ask you to
provide, or until you have something more to provide to me which might
help solve the issue, and might raise it's position in the queue.

Negativity/complaints, and whining, go to /dev/null

If you require instant solutions, use Red Hat Linux 8.0.  Phoebe is a
beta test product, and is not suitable for production use.

Alternatively, feel free to return to Windows, if you find that an
amiable solution that meets your needs.
Comment 17 Antonio Sanna 2003-01-24 15:04:05 EST
I don't want to come back to Windows! I don't want to make controversies! I am
only warry because I have seen that it is a big problem and I don't see a solution!
Excuse me for the reference to W.: I said so because I love Linux an I don't
want to come back! Then I'm "angry" because I can't install Phoebe, but I know
that RedHat an the developers are not guilty! Excuse me, truly!
Comment 18 Mike A. Harris 2003-02-05 21:22:48 EST
* Wed Feb  5 2003 Mike A. Harris <mharris@redhat.com>
- Updated CVS snapshot to
- Removed integrated patches XFree86-
- Add XFree86- to hopefully
  fix all the Radeon Xcursor related weirdness (#78231)

This might fix this problem.  Please test this new release
out when it is available in rawhide or my ftpsite, and update this bug report.
Comment 19 Nils Philippsen 2003-02-07 15:38:29 EST
Works for me (XFree86- For all I care, feel free to close it.
Comment 20 Dams 2003-02-08 06:03:11 EST
Fixed for me with XFree86- found in rawhide.
Thank you everybody.

Note You need to log in before you can comment on or make changes to this bug.