Bug 804466 - Inadequate Installation Guide XDMCP Server Instructions
Inadequate Installation Guide XDMCP Server Instructions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.2
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jack Reed
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 21:16 EDT by Ben.Stanley
Modified: 2013-06-17 01:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 18:37:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben.Stanley 2012-03-18 21:16:18 EDT
Description of problem:

The following bug describes a problem with the installation guide available at
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html-single/Installation_Guide/index.html#s2-trouble-remotex
Section 24.3.1. Remote Graphical Desktops and XDMCP

The documentation in this section fails in the following respects:
1) Fails to specify where in the /etc/gdm/custom.conf file the line "Enable=true" should be placed.
=> It must be placed after the [xdmcp] line.
2) Fails to properly explain how to re-start an already running gdm.
I did it by:
# telinit 4
# telinit 5
Note that if you "killall gdm", I had to resort to the above to re-start gdm(which is quite easy on distributions where gdm is run as a service, instead of directly from init).


Version-Release number of selected component (if applicable):
Seen on the internet at 19th March 2012. Claims to be Edition 1.0 in the front-matter.
Comment 2 Jack Reed 2012-08-23 00:51:55 EDT
Hi Ben,

Thanks for reporting this. I've implemented your first suggestion, but need clarification of the second.

You say that because you ran "killall gdm" that you had to resort to running telinit4 and telinit5. Is this the only circumstance you're referring to that would necessitate these telinit commands? Why is "killall gdm" a common enough risk that it should be documented in this section?

If there are other circumstances that you believe would benefit from the telinit commands to restart an already running gdm, what are they and at what point in the procedure should the commands be entered? After the /etc/gdm/custom.conf has been edited? Or at another point?

If you can help me overcome these ambiguities, I'll be better placed to update the documentation. Thanks in advance.
Comment 3 Ben.Stanley 2012-08-24 05:08:15 EDT
Jack,

Thanks for looking into this.

The problem is that when you change gdm's configuration file, you have to get gdm to re-load it for the new settings to take effect. In the case of gdm, this means re-starting it.

The instructions appear to be written under the assumption that that the system is not in runlevel 5 (that is, gdm is not running) when /etc/gdm/custom.conf is edited.

However, if the system is already in runlevel 5, and gdm is running, then the command
/sbin/init 5
or equivalently
telinit 5
will have no effect. Then it is necessary to somehow stop and re-start gdm. I accomplished it by:
1) telinit 4; # Stops gdm (and a whole bunch of other stuff)
   telinit 5; # Starts gdm (and a whole bunch of other stuff)

I also tried "killall gdm", but then I couldn't figure out how to re-start it without doing telinit4 and telinit5. There may be a more direct method of re-starting gdm, but I don't have time to figure it out for you.
Comment 4 Jack Reed 2012-09-26 21:47:39 EDT
Thanks, Ben. I see the problem now. I've added steps to the procedure for running init 4 and init 5 to restart the gdm and enact the changes in the config file.

The changes made for this bug will be available in the 6.4 version of the guide.
Comment 8 Jack Reed 2013-02-25 18:37:30 EST
This bug has been verified and implemented for 6.4, so I am changing the status to CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.