Bug 804487 - Revision History invalid with Publican 3
Revision History invalid with Publican 3
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 00:45 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.22.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-19 00:45:27 EDT
The Revision History generated by the Content Spec processor is invalid in Publican.


[jwulf@radhe Messaging_Installation_and_Deployment_Guide]$ csprocessor assemble
CSProcessor client version: 0.22.3
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Starting to validate...
Starting to build...
Content Specification successfully built with 0 Errors and 2 Warnings
Output saved to: /home/jwulf/scratch/Messaging_Installation_and_Deployment_Guide/assembly/Messaging_Installation_and_Deployment_Guide-publican.zip
Starting to assemble...
Content Specification build unzipped to /home/jwulf/scratch/Messaging_Installation_and_Deployment_Guide/assembly/publican
Starting the publican build...
revnumber (
					0-0
				) does not match the required format of '^([0-9.]*)-([0-9.]*)$/' at /usr/bin/publican line 632
Comment 1 Lee Newson 2012-03-19 01:04:10 EDT
I'm unable to reproduce this, so what version of publican are you using? By the looks of the regex expression it's matching it should be fine (though the "$/'" is sorta worrying). I should also note that that part hasn't changed since the program was created.
Comment 2 Joshua Wulf 2012-03-19 04:35:46 EDT
Ah....

Publican 3 from source.
Comment 3 Joshua Wulf 2012-03-19 19:50:37 EDT
A new book created with Publican 3 has the rev history formatted like this:

<revnumber>0.0-0</revnumber>
Comment 4 Lee Newson 2012-03-19 21:32:20 EDT
That doesn't matter, 0-0 will still work. The problem is that the older publican versions, used older PERL libraries which trimmed white space and newlines. It appears that the latest versions don't do this which is what is causing the problem. I still need to look into it more though.
Comment 5 Lee Newson 2012-03-25 20:02:34 EDT
Fixed in 0.22.4

I've made the <revnumber> tag be processed as an inline element. If anyothers pop up let me know. Though this is more of a publican issue in my opinion, as it should be able to handle white-space rather then all users having to enter <revnumber>0-0</revnumber> with no spaces.
Comment 6 Lee Newson 2013-06-06 21:30:40 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.