Bug 804492 - V7 should not pass the debug kernel in info when used for hardware tests.
V7 should not pass the debug kernel in info when used for hardware tests.
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-03-19 01:08 EDT by Meizhen Qi
Modified: 2015-02-08 16:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An enhancement has been made in v7 1.5 that now v7 will check kernel variant in `info` test and give a FAIL message if test is running on debug kernel.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add methods for checking if kernel is debug (3.15 KB, patch)
2012-03-20 10:20 EDT, Greg Nichols
no flags Details | Diff
info test patch adding check to see if kernel is debug (729 bytes, patch)
2012-03-20 10:21 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Meizhen Qi 2012-03-19 01:08:16 EDT
Description of problem:
in the cert: https://hardware.redhat.com/show.cgi?id=803195, the vendor used the kernel "Red Hat Enterprise Linux-debug (2.6.32-220.el6.i686.debug)" for all tests. But the v7 has not recognize it in info log. 

How reproducible:
1. uname information:
Linux localhost.localdomain 2.6.32-220.el6.i686.debug #1 SMP Wed Nov 9 08:21:32 EST 2011 i686 i686 i386 GNU/Linux

2. /boot/grub/grub.conf information: 
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux-debug (2.6.32-220.el6.i686.debug)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-220.el6.i686.debug ro root=UUID=6845bf87-455c-4a30-9231-dfd3f99b175e rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=128M rd_NO_LVM rd_NO_DM rhgb quiet
        initrd /initramfs-2.6.32-220.el6.i686.debug.img
title Red Hat Enterprise Linux (2.6.32-220.el6.i686)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-220.el6.i686 ro root=UUID=6845bf87-455c-4a30-9231-dfd3f99b175e rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=auto rd_NO_LVM rd_NO_DM rhgb quiet
        initrd /initramfs-2.6.32-220.el6.i686.img

3. kernel rpm information:

kernel-2.6.32-220.el6.i686                                  Mon 09 Mar 2009 09:17:39 AM PDT
kernel-debug-2.6.32-220.el6.i686                            Mon 09 Mar 2009 09:05:27 AM PDT
kernel-debuginfo-2.6.32-220.el6.i686                        Mon 09 Mar 2009 08:26:16 AM PDT
kernel-debuginfo-common-i686-2.6.32-220.el6.i686            Mon 09 Mar 2009 08:21:03 AM PDT
kernel-devel-2.6.32-220.el6.i686                            Mon 09 Mar 2009 08:32:41 AM PDT
kernel-firmware-2.6.32-220.el6.noarch                       Mon 09 Mar 2009 08:18:41 AM PDT
kernel-headers-2.6.32-220.el6.i686                          Mon 09 Mar 2009 08:18:20 AM PDT
kexec-tools-2.0.0-209.el6.i686                              Mon 09 Mar 2009 09:06:54 AM PDT
  
Actual results:
In the actual results, the v7 recognize it as the normal and there is not any error. 
The info log:  
Tested OS: Red Hat Enterprise Linux Server 6.2 (Santiago)
Kernel RPM: kernel-2.6.32-220.el6
v7 version 1.4, release 38
PASS         
+ rpm -ql kernel-2.6.32-220.el6
Boot Parameters: ro root=UUID=6845bf87-455c-4a30-9231-dfd3f99b175e rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=128M rd_NO_LVM rd_NO_DM rhgb quiet
PASS       
checking modules...
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686
kmod package: kernel-debug-2.6.32-220.el6.i686

Expected results:
The expected results is: there is an error in the outlog or the test result is failed, so that we can noticed it once the vendor use the debug kernel for tests.
Comment 4 Greg Nichols 2012-03-20 10:20:45 EDT
Created attachment 571426 [details]
patch to add methods for checking if kernel is debug
Comment 5 Greg Nichols 2012-03-20 10:21:46 EDT
Created attachment 571428 [details]
info test patch adding check to see if kernel is debug
Comment 9 Caspar Zhang 2012-06-04 03:57:02 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An enhancement has been made in v7 1.5 that now v7 will check kernel variant in `info` test and give a FAIL message if test is running on debug kernel.
Comment 11 errata-xmlrpc 2012-06-05 17:37:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.