Bug 80451 - Spurious APIC interrupt and ehternet
Spurious APIC interrupt and ehternet
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-26 14:26 EST by Tom Haynes
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 09:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Haynes 2002-12-26 14:26:22 EST
Description of problem:
running Compaq Proliant 5000 mdl 1x (1 cpu 200mhz Ppro, 128m ram, 2 eth using 
TLAN driver, embded fast-wide scsi2 controller,sd0 4.2gb,sd1 4.2gb,sd2 
4.2gb,sd3 4.2gb,sd5 CDROM,fd0 1.44mb)
Booted from floppy (bootnet.img from 8.0 cd) with command
   linux mem=exactmap mem=640K@0 mem=127M@1M
loaded TLAN.O driver (from drvnet.img) for 2 ethernet adapters (compaq net/flex 
and nettelligent)
network connection completed succesfully
ALT-F4 log read...
<4>TLAN: eth0: Link active
<6>spurious APIC interrupt on CPU#0, should never happen.
<6>spurious APIC interrupt on CPU#0, should never happen.
boot continued fine
When I could not mount the NFS image I tried to ping the computer I was 
installing linux on to make sure the link was good. for every ping sent to the 
computer a new line was added that said the same thing...
<6>spurious APIC interrupt on CPU#0, should never happen.
except for once when it said...
<4>spurious 8259A interrupt: IRQ7
IRQ 7 is for the ethernet card I have active
Have not completed install at this time (not related problem) to see if it 
hapen during runtime.

Version-Release number of selected component (if applicable):


How reproducible:
<6>spurious APIC... With 58 of 100 consecutive pings
<4>spurious 8259A... Only once (none during 100 pings)

Steps to Reproduce:
1.load TLAN module
2.ping IP address from remote station

    
Actual results:
sent 100 pings
58 resulted in <6>spurious APIC...

Expected results:
no output or <4>spurious 8259A...

Additional info:
Comment 1 Arjan van de Ven 2002-12-27 11:47:10 EST
could you try adding "apic" to your "mem=" line ?
Comment 2 Tom Haynes 2002-12-29 00:06:42 EST
I did get 7.1 to install. The main bug seemed to be a problem with the CD. 
However, I did a new install of 8.0 and could not get X to work, either from 
the install or after configuration from the shell. my CL-GD5420/512 worked with 
7.1 but would not work with 8.0. I used LORES and "RESOLUTION=..." commands. 
Xf86Config could not get X to work either. But, that is a different bug.
Comment 3 Alan Cox 2003-06-09 09:37:55 EDT
As of Red Hat 9 we dropped single processor APIC support as it causes problems
(like the one here). This should have solved it.


Note You need to log in before you can comment on or make changes to this bug.