Bug 804510 - [virtio-win][serial] Mouse can not use and vioserial-test still can receive data after disable virtio serial driver
[virtio-win][serial] Mouse can not use and vioserial-test still can receive ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 02:22 EDT by Mike Cao
Modified: 2012-03-19 16:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 16:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-03-19 02:22:19 EDT
Description of problem:


Version-Release number of selected component (if applicable):
# uname -r
2.6.32-252.el6.x86_64
[root@amd-2376-32-1 ~]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.248.el6rhev.x86_64

virtio-win-prewhql-24 guests

How reproducible:
100%

Steps to Reproduce:
1.start guest with virtio-serial-pci
CLI:/usr/libexec/qemu-kvm -M rhel6.3.0 -enable-kvm -m 8192 -smp 4,sockets=4,cores=1,threads=1 -name win2k8-R2 -uuid e2eaca3e-e764-f57b-22f0-74f4ab8c4965 -monitor stdio  -rtc base=localtime,driftfix=slew -drive file=/test/win2k8r2,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/root/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:15:af:6a,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -spice port=5910,disable-ticketing -vga qxl -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -bios /bios-tttt.bin -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x5 -chardev socket,id=charchannel0,path=/tmp/channel0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,name=com.redhat.rhevm.vdsm -device virtio-serial-pci,id=virtio-serial1,max_ports=16 -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial1.0,nr=1,chardev=charchannel1,id=channel1,name=com.redhat.spice.0
2.in the guest disable VirtIO Serial Driver in device manager 
3.in the guest #vioser-test.exe
4.press `r` in order to receive data  in a loop
5.Try to click sth in the guest via mouse 
  
Actual results:
after step4 every time press 'r' guest will receive a strange symbols amd sometimes the apps hang after "r" ,
After step 5 ,mouse is can not be used in the guest

Expected results:
every time press 'r' ,the app will show No 
whenever the mouse should work in the guest 


Additional info:
1.(qemu)info mice
* Mouse #0: QEMU PS/2 Mouse
2. after close the vioserial-test apps ,the mouse could use again.
Comment 2 Vadim Rozenfeld 2012-03-19 16:21:43 EDT
Hi Mike,

vioser-test is a simple, probably even too simple application for a very
brief vioserial device driver testing. It was not designed to work simultaneously with other vioserial connected applications. It doesn't have
any serious error handling and error recovery mechanism inside.
I'm going to remove this application from virtio-win build and create
a new, more serious test application sometime in the future.

BTW, vioser-test gets strange symbols because at that moment qemu still has
some unread data.

Closing this bug, because I'm not going to fix it.

Best regards,
Vadim.

Note You need to log in before you can comment on or make changes to this bug.