Bug 804514 - cannot boot into system with graphical mode installed with basic video driver
cannot boot into system with graphical mode installed with basic video driver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 02:45 EDT by Hongqing Yang
Modified: 2012-03-29 00:12 EDT (History)
10 users (show)

See Also:
Fixed In Version: mesa-8.0.1-9.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 00:12:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (18.13 KB, text/plain)
2012-03-19 02:45 EDT, Hongqing Yang
no flags Details
program log (48.10 KB, text/plain)
2012-03-19 02:45 EDT, Hongqing Yang
no flags Details
storage log (125.63 KB, text/plain)
2012-03-19 02:46 EDT, Hongqing Yang
no flags Details
syslog (75.19 KB, text/plain)
2012-03-19 02:47 EDT, Hongqing Yang
no flags Details
xlog (30.59 KB, text/plain)
2012-03-19 02:48 EDT, Hongqing Yang
no flags Details
ifcfg log (148 bytes, text/plain)
2012-03-19 02:49 EDT, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-03-19 02:45:08 EDT
Created attachment 571021 [details]
anaconda log

Description of problem:

after installation , got the error "Oh no! Something has gone wrong."
There are a lot of error in the program.log files.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2012-03-19 02:45:31 EDT
Created attachment 571022 [details]
program log
Comment 2 Hongqing Yang 2012-03-19 02:46:19 EDT
Created attachment 571023 [details]
storage log
Comment 3 Hongqing Yang 2012-03-19 02:47:19 EDT
Created attachment 571024 [details]
syslog
Comment 4 Hongqing Yang 2012-03-19 02:48:02 EDT
Created attachment 571025 [details]
xlog
Comment 5 Hongqing Yang 2012-03-19 02:49:50 EDT
Created attachment 571026 [details]
ifcfg log
Comment 6 Hongqing Yang 2012-03-19 02:50:42 EDT
The same error are also found in program.log that is installed without swap.
Comment 7 Chris Lumens 2012-03-19 10:15:45 EDT
There's nothing in your program.log that's a real error message.  It's just that some programs write output to stderr.  I believe the "Oh no!" message comes from gnome-shell, though.  Reassigning.
Comment 8 Hongqing Yang 2012-03-26 02:22:55 EDT
The system cannot boot into terminal one with F17 Beta RC1.
Comment 9 Adam Williamson 2012-03-26 11:11:00 EDT
Proposing as Beta blocker. Sounds somehow like Shell is trying to run via llvmpipe on VESA, and failing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2012-03-26 13:50:08 EDT
Discussed at 2012-03-26 QA meeting, acting as a blocker review meeting. Agreed that this is a blocker per the combination of Alpha criteria "The boot menu for all installation images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer and attempting to use the generic driver" and "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied" - the effect of these is that a 'basic video' installation should boot to a working desktop, which this bug suggests is not the case.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2012-03-26 14:13:03 EDT
I just tested and can't reproduce this in a VM at least. Did a basic video install, after install, gdm and shell both run okay. Somewhat jerky, but they run.

Hongqing, what hardware did you test on? Can you please provide some logs that would be useful here? As Chris says, this isn't an anaconda issue, it's Shell failing, so look in ~/.xsession-errors , maybe /var/log/messages .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Hongqing Yang 2012-03-27 02:03:03 EDT
I reproduced the same error with F17 Beta RC1. Below is my hardware detail:
http://www.smolts.org/client/show/pub_5f3281fe-1b27-40d0-9caa-70d01ef9ce5d
Comment 13 Hongqing Yang 2012-03-27 02:22:31 EDT
The ~/.xsession-errors  file does not exist.
Comment 14 Adam Williamson 2012-03-27 03:04:56 EDT
Tim's 807003 seems somewhat similar - both radeons having trouble with vesa, though one generation different (r520 vs. rv620).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2012-03-27 13:16:04 EDT
oh, if you get the 'oh no!' message when GDM should come up, look for /var/log/gdm/:0-greeter.log .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Jackson 2012-03-27 13:34:16 EDT
llvmpipe was super crashy with 16bpp until very recently.  It's still broken for texture-from-pixmap but at least it won't crash.  There's a mesa update in bodhi to fix that.
Comment 17 Fedora Update System 2012-03-27 13:35:23 EDT
mesa-8.0.1-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mesa-8.0.1-7.fc17
Comment 18 Fedora Update System 2012-03-28 01:56:56 EDT
Package mesa-8.0.1-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-8.0.1-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4799/mesa-8.0.1-7.fc17
then log in and leave karma (feedback).
Comment 19 Adam Williamson 2012-03-28 16:03:13 EDT
ajax: is 807003 likely to be a dupe of this?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Fedora Update System 2012-03-28 17:40:26 EDT
mesa-8.0.1-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mesa-8.0.1-9.fc17
Comment 21 Fedora Update System 2012-03-29 00:12:37 EDT
mesa-8.0.1-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.