Bug 804522 - anaconda failed to install using a software RAID device
anaconda failed to install using a software RAID device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:29b1029e703718993cee5d8dcc9...
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 03:15 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
9 users (show)

See Also:
Fixed In Version: lorax-17.13-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 00:12:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-0OPVaN (357.56 KB, text/plain)
2012-03-19 03:15 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2012-03-19 03:15:47 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-0OPVaN
hashmarkername: anaconda
kernel:         3.3.0-0.rc7.git0.3.fc17.i686
other involved packages: 
product:        Fedora
reason:         IndexError: could not find tree path
release:        Cannot get release name.
time:           Mon 19 Mar 2012 03:14:47 AM EDT
version:        17-Beta-TC2

anaconda-tb-0OPVaN: Text file, 366142 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.13 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/raid_dialog_gui.py", line 509, in __init__
:    selected_level = self.levelcombo.get_model()[level_index][0]
:  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1676, in editRaidArray
:    raiddev, isNew)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1566, in createCB
:    self.editRaidArray(array, isNew = True)
:IndexError: could not find tree path

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.Jzma_m
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:TZ=America/New_York
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Tao Wu 2012-03-19 03:15:52 EDT
Created attachment 571028 [details]
File: anaconda-tb-0OPVaN
Comment 2 Tao Wu 2012-03-19 03:20:51 EDT
anaconda 17.13 failed to testing partitioning On Software RAID, refer to 

 https://fedoraproject.org/wiki/QA:Testcase_Partitioning_On_Software_RAID
Comment 3 Tao Wu 2012-03-25 23:29:53 EDT
anaconda 17.14 still have this problem.
Comment 4 Adam Williamson 2012-03-26 11:14:53 EDT
Proposing as Beta blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2012-03-26 13:48:28 EDT
Discussed at 2012-03-26 QA meeting acting as a blocker review meeting. Agreed that this is a blocker per criterion "The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Brian Lane 2012-03-26 19:18:34 EDT
This is caused by noloader not loading modules before starting Anaconda.
Comment 7 Fedora Update System 2012-03-27 20:09:56 EDT
anaconda-17.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.15-1.fc17
Comment 8 Fedora Update System 2012-03-28 01:52:42 EDT
Package anaconda-17.15-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.15-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4745/anaconda-17.15-1.fc17
then log in and leave karma (feedback).
Comment 9 Tim Flink 2012-03-28 11:32:58 EDT
I was able to do a successful install onto SW Raid (VM w/ 2 virtio disks) with a custom boot.iso built with anaconda-17.15-1.fc17.

Not setting to verified because it wasn't an official image but it appears to be fixed.
Comment 10 Fedora Update System 2012-03-28 12:02:23 EDT
lorax-17.13-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lorax-17.13-1.fc17
Comment 11 Fedora Update System 2012-03-28 19:22:30 EDT
anaconda-17.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.16-1.fc17
Comment 12 Fedora Update System 2012-03-29 00:12:57 EDT
anaconda-17.16-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Tim Flink 2012-03-29 00:51:27 EDT
Successfully did an install onto SW Raid using F17 beta RC2.

Used VM with 2 virtio disks:
 - 1mb BIOS boot (vda)
 - 1024 /boot (vda, ext4)
 - 1025 swap (vdb)
 - rest of vda, vdb were made into sw raid1
Comment 14 Fedora Update System 2012-04-04 20:47:38 EDT
lorax-17.13-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.