Bug 804558 - grub2-mkconfig sorting fails to place 3.2.10 first.
grub2-mkconfig sorting fails to place 3.2.10 first.
Status: CLOSED DUPLICATE of bug 678840
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 05:09 EDT by Gilboa Davara
Modified: 2012-04-19 17:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 17:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub-mkconfig_lib sort patch (382 bytes, patch)
2012-03-21 07:32 EDT, Gilboa Davara
no flags Details | Diff

  None (edit)
Description Gilboa Davara 2012-03-19 05:09:31 EDT
As the title suggests, 3.2.10 was pushed to Fedora 16 mid-last-week.
grub2-mkconfig places it last (due to the 3.2.<1>0.
As suggested in GNU mailing list, sort version should be used instead of numerical sort.

Patch attached, tested on several machines.

- Gilboa
Comment 1 Hans Ecke 2012-03-20 14:10:06 EDT
Hi Gilboa-

I see the same bug. It is the version_test_numeric function within /usr/lib/grub/grub-mkconfig_lib which does not work very well. I'd love to see your fix, but I can not see any attachments to this bug. Are you sure you added it?

Cheers

Hans
Comment 2 Gilboa Davara 2012-03-21 07:32:01 EDT
Created attachment 571685 [details]
grub-mkconfig_lib sort patch

Sorry, my bad.
Comment 3 Hans Ecke 2012-03-21 11:26:07 EDT
Ah, I wasn't aware of the "-V" option to sort. Good to know. Works fine here. Could somebody please apply this patch (and/or submit to upstream)?
Comment 4 Gilboa Davara 2012-03-21 13:53:56 EDT
I'll free some time to create a patch against the actual grub package and post it here.
As I said in the OP, upstream is already aware of the problem (I've created the patch based upon the upstream suggested solution)

- Gilboa
Comment 5 Mads Kiilerich 2012-04-17 19:15:45 EDT
This has been fixed upstream in 2.0 beta 3.
Comment 6 Mads Kiilerich 2012-04-19 17:29:16 EDT

*** This bug has been marked as a duplicate of bug 678840 ***

Note You need to log in before you can comment on or make changes to this bug.