Bug 804615 - AUthconfig should add 'sss' to the 'services' line of nsswitch.conf
AUthconfig should add 'sss' to the 'services' line of nsswitch.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tomas Mraz
Iveta Wiedermann
:
Depends On:
Blocks: 848302
  Show dependency treegraph
 
Reported: 2012-03-19 08:45 EDT by Stephen Gallagher
Modified: 2012-08-15 04:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: authconfig-6.1.12-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848302 (view as bug list)
Environment:
Last Closed: 2012-06-20 10:30:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2012-03-19 08:45:16 EDT
Description of problem:
SSSD 1.8.0 and later now supports looking up 'services' via LDAP. Authconfig should add this map to the set that it adds 'sss' to when configuring LDAP functionality.

Version-Release number of selected component (if applicable):
authconfig-6.1.12-6.el6

How reproducible:
Every time

Steps to Reproduce:
1. Run authconfig and configure an LDAP or LDAP+KRB5 domain
  
Actual results:
/etc/nsswitch.conf is set up with 'sss' in the 'passwd', 'group' and 'netgroup' maps.

Expected results:
'sss' should be added to 'passwd', 'group', 'netgroup' and 'services'

Additional info:
This applies to RHEL 6.3 and later. This BZ should also be cloned to Fedora for F17.
Comment 2 RHEL Product and Program Management 2012-03-23 04:29:44 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 4 Tomas Mraz 2012-03-27 09:08:12 EDT
I've fixed it also in the upstream release authconfig-6.2.2
Comment 8 errata-xmlrpc 2012-06-20 10:30:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0931.html

Note You need to log in before you can comment on or make changes to this bug.