Bug 804634 - "duplicate key error index" on distributions when syncing two repos with the same source
"duplicate key error index" on distributions when syncing two repos with the ...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 09:46 EDT by Tomas Strachota
Modified: 2014-01-27 09:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 10:26:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Strachota 2012-03-19 09:46:22 EDT
Description of problem:

Synchroznization of product with two repos (having same source and holding some distributions) sometimes ends up with error
E11000 duplicate key error index: pulp_database.distribution.$_id_  dup key: { : "ks-Test Family-TestVariant-16-x86_64" }

Unfortunately this doesn't happen always. It looks like a race condition.


Version-Release number of selected component (if applicable):
pulp-1.0.0-5
katello-0.2.14-1


Steps to Reproduce:
1. create a product
2. add two repositories with the same source that hold some distro (eg. http://tstrachota.fedorapeople.org/dummy_repos/zoo/)
3. try to sync the product
Comment 2 James Laska 2012-04-18 09:59:05 EDT
Tomas, I assume this still happens and we can reproduce the problem?

Is there any fallout due to the log message?  
 1. It's not clear from your report ... does the sync fail?  
 2. If sync succeeds, are the synced repositories unusable?

If any of the above are TRUE, please set the 'cloudforms-1.0.0' and 'blocker' flags to '?'

If the problem is only a log message, please set the 'cloudforms-1.1.0' flags to '?'

Thanks!
Comment 3 Tomas Strachota 2012-04-19 04:33:43 EDT
Sorry for not being specific.

From my observation the sync fails only for one of the repositories. As they have the same source, the packages are available in Library at the end. Therefore I don't think this is a blocker. I also assume that having the same repos in one product is rather rare usecase.
Comment 4 Mike McCune 2012-04-19 12:38:50 EDT
moving to 1.1
Comment 5 Eric Helms 2012-12-18 10:26:21 EST
I am not able to reproduce this issue, and with the pending Pulp V2 integration upstream we can re-visit if this is found again.

Note You need to log in before you can comment on or make changes to this bug.