Bug 804676 - Cheese can't take a picture
Cheese can't take a picture
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 11:00 EDT by Elad Alfassa
Modified: 2012-03-20 22:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 22:58:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad Alfassa 2012-03-19 11:00:33 EDT
Description of problem:
Trying to take a picture with cheese, the countdown works, but when it ends, nothing happens, and the buttons are not sensitive (disabled).

Version-Release number of selected component (if applicable):
cheese-3.3.90-2.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Start cheese
2.Try to take a photo
3.
  
Actual results:
No picture is taken, UI buttons stay not sensitive (disabled).

Expected results:
Picture is taken after the countdown, UI buttons enabled again and ready to take more pictures.

Additional info:

Gtk-DEBUG: Connecting to session manager

Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkToggleButton, but as a GtkBin subclass a GtkToggleButton can only contain one widget at a time; it already contains a widget of type GtkLabel

Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkToggleButton, but as a GtkBin subclass a GtkToggleButton can only contain one widget at a time; it already contains a widget of type GtkLabel

Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkToggleButton, but as a GtkBin subclass a GtkToggleButton can only contain one widget at a time; it already contains a widget of type GtkLabel

Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkButton, but as a GtkBin subclass a GtkButton can only contain one widget at a time; it already contains a widget of type GtkLabel

Gtk-WARNING **: Attempting to add a widget with type GtkGrid to a GtkToggleButton, but as a GtkBin subclass a GtkToggleButton can only contain one widget at a time; it already contains a widget of type GtkLabel

Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkButton, but as a GtkBin subclass a GtkButton can only contain one widget at a time; it already contains a widget of type GtkLabel

** CRITICAL **: cheese_main_window_finish_countdown_callback: assertion `self != NULL' failed

Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed


The problem is probably due to the assertion failure in cheese_main_window_finish_countdown_callback

Marking as final blocker as per criteria:
All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items 

A webcam application should be able to take pictures, this is basic functionality.
Comment 1 Elad Alfassa 2012-03-19 11:02:36 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Matthias Clasen 2012-03-20 22:58:39 EDT
Fixed in cheese-3.3.92-1.fc17

Note You need to log in before you can comment on or make changes to this bug.