Bug 804730 - Updates in Getting Started with Mobile RichFaces needed
Updates in Getting Started with Mobile RichFaces needed
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: doc-Getting-Started-With-Mobile-RichFaces (Show other bugs)
2.0.0.ER3
Unspecified Unspecified
medium Severity medium
: GA
: 2.1.0
Assigned To: WFK Docs Team
Pavol Pitonak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 12:51 EDT by Pavol Pitonak
Modified: 2013-06-27 08:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 08:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Pitonak 2012-03-19 12:51:28 EDT
Description of problem:
There were some changed made in community version of this document. Productized document should be updated accordingly.
https://community.jboss.org/wiki/GettingStartedWithMobileRichFaces

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
1. The second paragraph refers to RichFaces 4.1.0, latest version is 4.2.0 which will probably change in future. Consider ommiting RichFaces version in the document.
2. The first code snippet is not indented correctly.
3. The context parameter in first code snippet should be changed from org.richfaces.resourceMapping.enabled to org.richfaces.resourceOptimization.enabled

Additional info:
Comment 1 Karel Piwko 2012-06-04 06:55:25 EDT
Retargeted to 2.0.0.GA
Comment 2 Rebecca Newton 2012-06-11 20:44:40 EDT
Further information from Bruno Oliveira on required updates, correspondence from email:


Following our recent updates on Aerogear we need to replace the term POH5 from the docs. I would like to suggest some changes.

* In the abstract section (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_HTML5_Mobile_Web_Development/index.html).

"This book is a guide to getting started with HTML5 and REST. This approach uses a pure HTML5 based front-end that interacts with server-side content through RESTful endpoints."

* At the section 2.2 (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_HTML5_Mobile_Web_Development/jboss-feedback.html)

I would like to replace "the component doc-Getting-Started-With-HTML5-Mobile-RichFaces" by "the component doc-Getting-Started-With-HTML5-Mobile-Web-Development-With-JBoss". Just to keep compatible with our reference on Aerogear site.

* At the getting started section 1.1 (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_HTML5_Mobile_Web_Development/ch01.html)

"This guide is a walkthrough of creating a new HTML5 mobile application with REST resources using a Maven archetype, deploying it to the JBoss Enterprise Application Platform 6, and executing server/client test suites. It also provides an overview of basic behaviour of the application including both command line and JBoss Developer Studio instructions."

* At the Step two section 1.2.1 (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_HTML5_Mobile_Web_Development/sect-deploying.html) feel free to update to 1.0.0.M4

"mvn archetype:generate \
     -DarchetypeArtifactId=jboss-html5-mobile-archetype \
     -DarchetypeGroupId=org.jboss.aerogear.archetypes \
     -DarchetypeVersion=1.0.0.M4"
     

* In the section 1.3 (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_HTML5_Mobile_Web_Development/ch01s03.html), images should be updated (I just attached them to this e-mail)

* The chapter 2 (http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_HTML5_Mobile_Web_Development/chap-further-info.html) is outdated. Please take a look here https://community.jboss.org/wiki/HTML5MobileQuickstartArchetypeDeepDive
Comment 3 Rebecca Newton 2012-06-12 01:09:56 EDT
Whoops, got my getting started guides mixed up!
Comment 4 Rebecca Newton 2012-06-15 00:54:24 EDT
For the first half of this bug (and the correct half!), the GSG with Mobile RichFaces, the results of my corrections will be available here very soon:

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_Mobile_RichFaces/index.html

I had to take out the XML highlighting for the third code sample because it was rendering incorrectly. Thanks for the feedback, Pavol.

Bec
Comment 5 Pavol Pitonak 2012-06-15 07:50:26 EDT
Rebecca, there is still wrong indentation in the second code sample (tag  <link>) in chapter 2.

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2/html/Getting_Started_With_Mobile_RichFaces/ar01s02.html
Comment 6 Rebecca Newton 2012-06-17 19:30:00 EDT
Hey Pavol, should it all be in line with each other like this:

<link rel="stylesheet" href="https://raw.github.com/richfaces/components/develop/mobile-compatibility/slidfast.css" />
 
<script type="text/javascript" src="https://raw.github.com/richfaces/components/develop/mobile-compatibility/slidfast.js"></script>
 
<script type="text/javascript">
slidfast({
               defaultPageID:'home-page',
               defaultPageHash: 'home',
               backButtonID: 'back-button'
           });
</script>]]>

I tweaked it a bit more, it should work this time.
Comment 7 Pavol Pitonak 2012-06-18 04:34:55 EDT
Yes, now it looks good :)
Comment 8 Pavol Pitonak 2012-06-18 08:46:31 EDT
Bec, 

last code sample in the second chapter refers to old archetype.

-DarchetypeVersion=4.2.1.Final

The most recent (and correct) version is 4.2.2.Final
Comment 9 Isaac Rooskov 2012-08-08 21:04:50 EDT
Hey Pavol I have updated the guide to reflect the version of RichFaces mentioned in that code sample as being 4.2.2.Final. 

It should be live within the hour (by the time you see this), can you please verify.

Thanks, 

Isaac
Comment 10 Pavol Pitonak 2012-08-13 08:47:32 EDT
It is ok now.
Comment 11 Pavol Pitonak 2012-10-30 05:52:04 EDT
Isaac, 

there is wrong version of RichFaces, archetype version is 4.2.3.Final (chapter 2). There is also WFK 2.0.0 mentioned, it should be changed to 2.1.0.

Note You need to log in before you can comment on or make changes to this bug.