Bug 80477 - Installer sets default run level to 5 without asking
Installer sets default run level to 5 without asking
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-26 20:10 EST by Michael Fratoni
Modified: 2007-04-18 12:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 01:34:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Fratoni 2002-12-26 20:10:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
During a clean install, the installer doesn't ask if it should set the default
run level to 5. It appears that if you configure X, you get a GUI login.

I'd like the option of configuring X, yet still booting into text mode. I
believe the installer always asked in the past?

Additionally, I selected both Gnome and KDE packages for installation.
The installer never asked which desktop I would prefer as default. This also
occured in the 8.0 release, if I recall correctly. Again, the installer always
asked in the past.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Actual Results:  On first boot, the system came up in graphical mode with Gnome
as the desktop manager.

Expected Results:  The installer should have asked about the default run level,
as well as the default desktop manager.

Additional info:

Perhaps this is just personal preference, but I don't ever want a system
starting in run level 5. I much prefer a well mannered installer that is polite
enough to ask before arbitrarily setting default run levels and desktop managers.
Comment 1 Michael Fulbright 2002-12-27 11:20:04 EST
Did you choose Personal Desktop or Workstation?

We do not ask this question now for these installation options.
Comment 2 Michael Fratoni 2002-12-27 18:50:51 EST
I selected a Workstation install. 

Which question doesn't get asked for this install selection, the default
runlevel, or the choice of desktops? While I can live with starting in GUI mode
by default, the installer should still ask which desktop to make the default
when both Gnome and KDE are selected.

Ideally the installer should ask for both issues.
Comment 3 Elton Woo 2002-12-28 16:00:16 EST
Previous installations of RH linux provided the option of *testing* the
resolution, before finalizing
the install routine. I did not get this option when selected 24-bit, 1024 x 768.
Is there a reason that this option was removed? What would happen if the user
selected the _wrong_ resolution?

IMHO, this is a very important step which should have been retained in the
install process.

Also, I selected "Custom" install, nonetheless, I did NOT get the option of
selecting which
WM I wanted as the login manager. As much as I like Gnome, I would like to have
the choice
of selecting either KDE *or* Gnome as the login manager.
Comment 4 Bill Nottingham 2002-12-31 22:52:51 EST
Mike was referring to not asking the runlevel question in workstation or
personal desktop.
Comment 5 Jeremy Katz 2003-01-10 01:34:19 EST
Workstation and Personal Desktop installs will default to runlevel 5.  Those who
don't really want that know enough to change it themselves.  The test button was
removed due to multiple driver/card combos causing lockups if you had multiple
servers running at once.

Note You need to log in before you can comment on or make changes to this bug.