Bug 804797 - Make new NM VLAN and Bond functionality disabled-by-default
Make new NM VLAN and Bond functionality disabled-by-default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Williams
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 15:41 EDT by Dan Williams
Modified: 2012-06-20 09:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2012-03-19 15:41:00 EDT
To ensure that people aren't surprised by the new support for these connections, we want to disable this functionality by default and only enable it when a key in a config file is set.
Comment 1 RHEL Product and Program Management 2012-03-19 15:49:54 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 3 Dan Williams 2012-03-23 14:53:41 EDT
The mechanism is that NM will now read NM_BOND_VLAN_ENABLED in /etc/sysconfig/network.  If and only if that key is present and is one of "yes", "y", or "true", will NetworkManager detect and manage bonding and vlan interfaces.

If that key is missing or "no"/"false", you should *not* see NetworkManager do any of the following:

1) detect and manage bonding or VLAN interfaces
2) create bonding or VLAN interfaces as a result of writing a bond/vlan ifcfg file to /etc/sysconfig/network-scripts
3) successfully activate a bond/VLAN connection when initiated via 'nmcli con up uuid <uuid of bond/vlan connection>"

NM will still parse and read bond/vlan ifcfg files, but it will simply ignore any bond/vlan interfaces and should not create them unless NM_BOND_VLAN_ENABLED=yes.
Comment 7 errata-xmlrpc 2012-06-20 09:42:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0832.html

Note You need to log in before you can comment on or make changes to this bug.