Bug 804813 - repo type "nfsiso" unsupported (mount: unknown filesystem type 'nfsiso')
repo type "nfsiso" unsupported (mount: unknown filesystem type 'nfsiso')
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-19 16:14 EDT by Dr. Tilmann Bubeck
Modified: 2012-04-04 17:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 17:44:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. Tilmann Bubeck 2012-03-19 16:14:36 EDT
Description of problem:

If I use repo=nfsiso:10.2.1.1:/home/install/fedora/17/x86-64/iso on PXE then the installation stops with "mount: unknown filesystem type 'nfsiso'"

Version-Release number of selected component (if applicable):
Fedora-17-Beta-TC2-x86_64-DVD.iso

How reproducible:
Any time

Steps to Reproduce:
1. Boot PXE
2. Give boot argument repo=nfsiso:10.2.1.1:/home/install/fedora/17/x86-64/iso
  
Actual results:
Above error message

Expected results:
Mounting ISO image and installing


Additional info:
Comment 1 Harald Hoyer 2012-03-20 07:44:27 EDT
does it work with "nfs://" ?
Comment 2 Dr. Tilmann Bubeck 2012-03-20 08:08:36 EDT
yes.
Comment 3 Will Woods 2012-03-20 08:59:11 EDT
Should be fixed in anaconda git, f17-branch:
  8d5d4b9 dracut: fix anaconda-netroot for inst.repo=nfsiso:..
Comment 4 Kamil Páral 2012-03-20 09:23:51 EDT
Proposing as Beta blocker.
"The installer must be able to use the HTTP, FTP and NFS remote package source options"
https://fedoraproject.org/wiki/Fedora_17_Beta_Release_Criteria
Comment 5 Adam Williamson 2012-03-21 17:57:10 EDT
This should be fixed by:

https://admin.fedoraproject.org/updates/dracut-017-59.git20120321.fc17



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Kevin Fenzi 2012-03-21 18:55:22 EDT
+1 blocker
Comment 7 Jared Smith 2012-03-21 19:05:27 EDT
+1 blocker
Comment 8 Adam Williamson 2012-03-21 19:11:27 EDT
I'm +1 as well, 4 +1s (counting Kamil's proposal), accepted per criterion "The installer must be able to use the HTTP, FTP and NFS remote package source options" - nfsiso is one of the two NFS cases.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Bruno Wolff III 2012-03-21 22:27:00 EDT
+0 blocker (it sounds like there is and easy work around) +1 NTH
Comment 10 Adam Williamson 2012-03-24 12:17:54 EDT
We have a new enough dracut in Beta RC1, can someone re-test? thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Dr. Tilmann Bubeck 2012-03-24 16:24:42 EDT
Works for me in Beta RC1.
Comment 12 Adam Williamson 2012-03-24 16:55:48 EDT
Excellent. The new dracut is stable, so let's close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Dr. Tilmann Bubeck 2012-04-04 14:34:20 EDT
The bug appears (again) in Beta RC3. Same error as stated intially:

"mount: unknown filesystem type 'nfsiso'"

But there is no workaround by using repo type "nfs" instead of "nfsiso". It fails too.
Comment 14 Adam Williamson 2012-04-04 17:14:03 EDT
I disagree. I've successfully tested both repo=nfsiso:192.168.1.x:/fedora and repo=nfs:192.168.1.x:/fedora installs. What parameter did you use exactly? What image are you testing with?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2012-04-04 17:28:33 EDT
Did you use PXE during your test, or not?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2012-04-04 17:32:12 EDT
Actually, we think this is almost certainly the same as http://bugzilla.redhat.com/show_bug.cgi?id=810005 . There's a bug with parameter splitting when the repo= parameter is handled early because it's needed to find stage2. There is a workaround described in that bug - pass a root= parameter as well as a repo= parameter.
Comment 17 Adam Williamson 2012-04-04 17:44:44 EDT
Discussed at 2012-04-04 go/no-go meeting. We agreed that we're pretty sure Till's case is #810005, and two other testers (myself and j_dulaney) confirm that nfsiso works fine with a DVD/netinst boot, so this bug should be closed again, and Till can follow up in #810005. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.