Bug 804836 - Kernel trace dump on bootup
Kernel trace dump on bootup
Status: CLOSED DUPLICATE of bug 808603
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-03-19 17:51 EDT by greg.hellings
Modified: 2012-04-04 07:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-04-04 07:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
First portion of kernel dump (1.41 MB, image/jpeg)
2012-03-25 00:55 EDT, greg.hellings
no flags Details
Second portion of kernel dump (2.05 MB, image/jpeg)
2012-03-25 00:56 EDT, greg.hellings
no flags Details
Final portion, post dump (1.73 MB, image/jpeg)
2012-03-25 00:56 EDT, greg.hellings
no flags Details

  None (edit)
Description greg.hellings 2012-03-19 17:51:48 EDT
Description of problem:
A freshly installed Fedora 17 beta install on my Toshiba Satellite laptop throws a kernel dump when booting after initializing the swap but before mounting my /home partition.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 17 Beta TC1
2. Select standard boot option
3. Wait until mount space is loaded
Actual results:
Kernel error as reported below

Expected results:
System should begin first boot

Additional info:
Linux 3.3.0-0.rc7.git0.3.fc17.x86_64 from the image dated 07-March-2012

Output from kernel seems to begin with these lines, where I haven't copied the time stamp after the first line
[  26.917916] BUG: unable to handle kernel NULL pointer dereference at    (null)
IP: [<ffffffff813267f8>] strncpy+0x18/0x30
PGD 18ddb2067 PUD 18dc2e067 PMD 0
Oops: 0000 [#1] SMP
Modules linked in: arc4 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev i2400m_usb(+) i2400m v412_compat_ioctl32 wimax media microcode snd_hda_intel(+) snd_hda_codec i2c_i801 snd_hwdep iTCO_wdt jmb38x_ms iwlwifi r8169 snd_pcm iTCO_vendor_support memstick snd_page_alloc mli mac80211 snd_timer cfg80211 snd toshiba_acpi(+) soundcore sparse_keymap rfkill uinput sdhci_pci sdhci mmc_core i915 video i2c_algo_bit drm_kms_helper drm i2c_core

Pid: 459, comm: biosdevname Not tainted 3.3.0-0.rc7.git0.3.fc17.x86_64 #1 TOSHIBA Satellite A665/PHQAA
RIP: 0010:[<ffffffff813267f8>] [<ffffffff813267f8>] strncopy+0x18/0x30

And so on. I can reproduce and send further data if it would be of any assistance. This appears to be a regression since Fedora 16, which ran on this system fine until 2 days ago when I tried to do a fresh install of Fedora 17 beta.
Comment 1 Dave Jones 2012-03-19 18:50:44 EDT
we need the whole trace.
Comment 2 greg.hellings 2012-03-19 21:00:55 EDT
Any suggestions how to accomplish that short of copying from one screen to the other by hand as the above partial output gives? Would that be logged to /var/log somewhere?
Comment 3 Dave Jones 2012-03-20 11:41:24 EDT
take a photo of the trace with a camera ?

the kernel kdump feature *should* work in f17, but requires some setup, we're working towards making that easier.
Comment 4 greg.hellings 2012-03-25 00:55:39 EDT
Created attachment 572482 [details]
First portion of kernel dump
Comment 5 greg.hellings 2012-03-25 00:56:21 EDT
Created attachment 572483 [details]
Second portion of kernel dump
Comment 6 greg.hellings 2012-03-25 00:56:49 EDT
Created attachment 572484 [details]
Final portion, post dump
Comment 7 greg.hellings 2012-03-25 00:57:52 EDT
I have attached pictures of the dump starting from where the Bug is first detected and continuing down through the point where bootup is stalled. This is after updating to the Beta RC dated March 23.
Comment 8 Stanislaw Gruszka 2012-04-04 07:10:08 EDT

*** This bug has been marked as a duplicate of bug 808603 ***

Note You need to log in before you can comment on or make changes to this bug.