Bug 804843 - repackage mongoose, incl. shared library and -devel
repackage mongoose, incl. shared library and -devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mongoose (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rafael Aquini
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 18:30 EDT by Frank Ch. Eigler
Modified: 2012-08-29 16:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 18:27:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2012-03-19 18:30:18 EDT
mongoose appears to be a decent library to build baby httpd applications with, but the fedora package only creates the /usr/bin/mongoose demo application.  Please consider building mongoose also into a -libs and -devel subrpms, so that apps that want to use mongoose purely as a library may do so.
Comment 1 Rafael Aquini 2012-06-05 15:56:04 EDT
Howdy Frank, (and sorry for this late reply)

That's good feedback, and I'll be working on repackaging it (as I completely agree with you on that). 
Those subpkgs are not present today because by the time I propose mongoose for review, it was done including the lib and devel subpacks, but reviewers were unhappy with that approach at that time, IIRC.

Cheers!
-- aquini
Comment 2 Rafael Aquini 2012-07-05 21:52:52 EDT
Howdy Frank,

Would you mind in reviewing the RPM before I commit the SPEC to git and submit a new rawhide build for mongoose?

SPEC: http://aquini.fedorapeople.org/mongoose/mongoose-3.1.spec
SRPM: http://aquini.fedorapeople.org/mongoose/mongoose-3.1-1.fc17.src.rpm
KOJI: http://koji.fedoraproject.org/koji/taskinfo?taskID=4222121

Please, do not hesitate on giving me your thoughts!

Cheers!
-- aquini
Comment 3 Frank Ch. Eigler 2012-07-11 16:41:19 EDT
Looks good to me, thanks!
Comment 4 Rafael Aquini 2012-07-17 16:00:37 EDT
New rawhide build for mongoose:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4247046
Comment 5 Fedora Update System 2012-07-17 16:05:57 EDT
mongoose-3.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mongoose-3.1-1.fc17
Comment 6 Fedora Update System 2012-07-19 05:09:12 EDT
Package mongoose-3.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mongoose-3.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10832/mongoose-3.1-1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-07-26 18:27:06 EDT
mongoose-3.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-08-21 08:56:58 EDT
mongoose-3.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mongoose-3.1-1.fc16
Comment 9 Fedora Update System 2012-08-29 16:25:09 EDT
mongoose-3.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mongoose-3.1-2.fc16

Note You need to log in before you can comment on or make changes to this bug.