Bug 804864 - [abrt] evolution-data-server-3.2.3-2.fc16: Process /usr/libexec/e-calendar-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.2.3-2.fc16: Process /usr/libexec/e-calendar-fa...
Status: CLOSED DUPLICATE of bug 755791
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:0ccba8e3d49b7a56720017e2835...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 21:20 EDT by Kahlil Hodgson
Modified: 2012-03-22 06:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 06:52:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (8.30 KB, text/plain)
2012-03-19 21:20 EDT, Kahlil Hodgson
no flags Details
File: maps (38.16 KB, text/plain)
2012-03-19 21:20 EDT, Kahlil Hodgson
no flags Details
File: backtrace (31.64 KB, text/plain)
2012-03-19 21:20 EDT, Kahlil Hodgson
no flags Details

  None (edit)
Description Kahlil Hodgson 2012-03-19 21:20:17 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/libexec/e-calendar-factory
comment:        trying to accept an appointment to my default google calendar.  though this was fixed by most recent update
executable:     /usr/libexec/e-calendar-factory
kernel:         3.2.3-2.fc16.x86_64
pid:            1745
pwd:            /
reason:         Process /usr/libexec/e-calendar-factory was killed by signal 11 (SIGSEGV)
time:           Tue 20 Mar 2012 12:01:28 EST
uid:            1000
username:       kal
xsession_errors: 

backtrace:      Text file, 32401 bytes
dso_list:       Text file, 8498 bytes
maps:           Text file, 39074 bytes

build_ids:
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:ccd23fb93a7924ddd27ea9e7f054fa5309c92f32
:2976a5f82b01d5dedaaefdd41fa7a78b090c75a1
:89017ab0b75e533e4294f74ee8f7db3daceea536
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:edebfad67bdac472272d049dc7ec302f47b02f32
:638db099ff5fb986d1a092629d1bb1dca5be4904
:aaf62304b0fc10611d35b4f56005479d4c58868d
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:0bd515c1c778bb4b8f870a900d1543da39d6b662
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:58f626f3815dd6adeb4a543bca2472ab98f2953b
:56cd5a4b8ecf7f375c95a4fd575895efbe294071
:a0b2903547454e47fec356c1fa1a69a7593893c5
:2639b5594fe4d7897db63ecd1ebb9681438317a8
:a4aa4dbbde0442f619ec6e181401f35a165a1ad7
:0fe03f2aa418c7dbfdc2d0d1802a8e86b27d3120
:34e8b3cee73a6d0b8ac17c69ba4b1170724db64c
:37c84b700d36cedd486ab4259d4fb8cd34eb0d6b
:545fac2346ca24589041213956b7f22f7e91c139
:b364cd223f6f7064d01b8b21014531be0fc74a47
:59292332bd88fce31f7557e60ff08d44ce254ec8
:dc998e8c1e1dc44c684b9b86e753945a868e134a
:ec72f897bbac2f33aadee57e01b7e01bbed4c534
:ef95ed2b74ff19753827117d4e556f38b33e74b5
:f0d50e3af2dfee021a327fb85a993a2312a98145
:0a49b6fd90960659888f0be3bb576495f9d41959
:67aac0b79f10ac5dbd5e4e9253639121570ff317
:6ecc3efaedf849a17c30a67fe15b4dacca1bd981
:ea44661a40777d6be2f79058c161d3bb4962891a
:48aea888319e1848137073c9cbde54a4c2a731c9
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:474978b2eb0c0e3764a749d9852a9f47efe7043f
:be507c791e34415e8f42f0e6030c889b2895cf9a
:0fccce2fdb46650674ef5b64fae5f25f14c88e08
:c6739204320eb15bdcdba039a2b183298170403e
:c5e777db418e7b567423c9ee00a707a172a7f824
:3269336f76283d9cebaa8222e0017c80fd14bdf6
:7e38d4068ce4d86cb3f22c2676cbe7f8bdccc15d
:d7f6c1be742b45c9676d04bb128817013d761d35
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:ee2f04900ae1f07517d91eba300ef385fccab1b8
:fd8a00c88eb1fd6872e45001f9ed4e5c6172995e
:065f24e263b3a0d4316bfeedf855df8c2c35c03a
:0d660a4db2aecb2346e3ef73975137341f48baac
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:a33bb965b6b704eb920e084ebd8325cf1408c05a
:701c8cd759f655fae8c102c779740becb24ee061
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:96f8ca7cdedbacc6753c9144239a8af15495e0c0
:163b323da65b708418226eb5fa8b057c731d1475
:e2e67b3ae2579e1667b73ad385f61552931024e9
:0911ea7c180d733724f89037b8e8a34e64024aec
:0406dc93e5d067b98e166932201a6df7dde67888
:6502dd4813f98137c70e6e05cc43828f5c2263c1
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:4c842320387ff7f6f91b7842b223c16518be909f
:b1e242d5084d86e916e73640e367d5c052097f48
:07470201df55a5254027d05fa4dc509b10f2986a
:d059477f31920d955bf6e4547224fb0a1a9c0f7b
:e814ef8432b7dec42a0b8ec12b9abd9fc7f57b40
:a28b15796672928bb44b262c88052ae601bf5955
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:2670385f49fb9f120f7cf843f211e3c620da8632
:36fc045d11fc55f1b455247938e651666e2c127e
:d2ddca668b36423bb3a66540e10f99d60511978e
:f1e8182609d9eae40a8ddbbb72c9346166014f1a
:1c6a95451ee19617be5abea3d121f0226d21ddda
:b010321c92dc1b5abf0007da423b778542817883
:8764055a87ed1f591ac8e2304b791e66d7e23892
:28fefa0d4f9eae933375f595bad72153c8f83db6
:e5429e0905bedecc534b057783916ba43e06a66e
:b492837dde7c9f97bee3e688aa7a2eb39ed1666a
:4953d1f613914126bccceb3cb96386647ffba9df
:eb10316194bb89661ab56fe05ac01afa7c5c3dec
:3a09f72b6c0715e6339597e51c4d8a1e0c472286
:29e5c77a320ced9a78afa3ea20bd4f4ab92c42aa
:e17eba0db37de02eb984c3dba5db3ba21ae809c8
:b9d3a4213a482d034bebc7dc1ed2901a734a894d
:d7562dba664dbd5f00f62a32c4b68828e0a09b1a
:e2d68a0ee0872365dcc8c6640b7cd7b94c8276f2
:83cb4627bed5c756d4e6f23badf8a6b4b042f4e6
:b9077d01c85890adb45d3769a96fa5a75955f4fb
:e567a4b498aa9dfc484575e666a17925f0944318
:c8e7f118041a9f77e0dd673da11b5653be27b5a2
:6b86f13a5143c43fdec686daebd48abb3dd91c8e
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:a518a8b1b5c3e80dee813df05e951d205d6ac48c

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-AuDiKumGtk,guid=35addb03f5aa33682b1e177c00000023
:XDG_SESSION_COOKIE=e4a9746f1cc4f117f4ccc9930000000c-1332195249.484014-766584234
:XDG_RUNTIME_DIR=/run/user/kal
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/tmp/keyring-sfbnPB/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1453,unix/unix:/tmp/.ICE-unix/1453
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=kal
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/tmp/keyring-sfbnPB/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-AuDiKumGtk,guid=35addb03f5aa33682b1e177c00000023
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-kal-NkkMjB/database
:USER=kal
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1447
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/kal
:GNOME_KEYRING_CONTROL=/tmp/keyring-sfbnPB
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=kal
:HOME=/home/kal

smolt_data:
:
:
:General
:=================================
:UUID: 7119cb7a-4adc-4756-a647-93460cbfc1b4
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_AU.UTF_8
:Platform: x86_64
:BogoMIPS: 5581.37
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2801
:System Memory: 7764
:System Swap: 9887
:Vendor: LENOVO
:System: 4286CTO ThinkPad X220
:Form factor: Notebook
:Kernel: 3.2.3-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7247:6058:8666) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(4147:404:6058:8666) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:294:6058:8666) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7171:6058:8666) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7184:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7192:6058:8666) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8666) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7202:6058:8666) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:133:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(4480:59426:0:0) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(32902:7213:6058:8666) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8666) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8666) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8666) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_eric-lv_root / ext4 4096 4096 13092026 10765161 10634139 3276800 3074087 3074087
:/dev/sda1 /boot ext4 1024 1024 508745 407667 382067 128016 127737 127737
:/dev/mapper/vg_eric-lv_home /home ext4 4096 4096 23262022 8896033 7731131 5824512 5653805 5653805
:

var_log_messages:
:Mar 19 10:24:29 eric abrt[24745]: File '/usr/libexec/e-calendar-factory.#prelink#.V1h7Tu' seems to be deleted
:Mar 19 10:24:29 eric abrt[24745]: File '/usr/libexec/e-calendar-factory.#prelink#.V1h7Tu' seems to be a prelink temporary file
:Mar 19 10:24:29 eric abrt[24745]: Saved core dump of pid 1775 (/usr/libexec/e-calendar-factory) to /var/spool/abrt/ccpp-2012-03-19-10:24:29-1775 (77488128 bytes)
:Mar 20 12:01:28 eric abrt[26802]: Saved core dump of pid 1745 (/usr/libexec/e-calendar-factory) to /var/spool/abrt/ccpp-2012-03-20-12:01:28-1745 (77631488 bytes)
Comment 1 Kahlil Hodgson 2012-03-19 21:20:22 EDT
Created attachment 571259 [details]
File: dso_list
Comment 2 Kahlil Hodgson 2012-03-19 21:20:24 EDT
Created attachment 571260 [details]
File: maps
Comment 3 Kahlil Hodgson 2012-03-19 21:20:27 EDT
Created attachment 571261 [details]
File: backtrace
Comment 4 Milan Crha 2012-03-20 03:58:35 EDT
> comment:        trying to accept an appointment to my default google calendar. 
> though this was fixed by most recent update

Thanks for a bug report. You've right this particular issue should be fixed with evolution-data-server 3.2.3-2. The first line of the backtrace says:
> warning: core file may not match specified executable file.
which might mean that the e-calendar-factory process (similar with e-addressbook-factory) is still running from the previous version of evolution-data-server, aka it was not restarted yet. Am I right?
Comment 5 Kahlil Hodgson 2012-03-20 05:47:06 EDT
Good point.
Hmmm ... memory is a bit hazy so lets check the logs: 
yum log says evolution was updated to 3.2.3-2 at 09:12.
messages says I rebooted at 12:03.  
I submitted the bug report around 12:20 so all should be fresh from the update.
Comment 6 Kahlil Hodgson 2012-03-20 16:56:42 EDT
Just realized that I had previously tried to accept this invitation, which caused the crash noted in previous bug reports. Since the update, I tried to accept the invitation again and got the above crash.  Perhaps there is something (file, db entry, ...) left lying around from the previous crash that is blocking the 2nd attempt at accepting?  

I've also noticed that there is corresponding entry in my calendar (not sure which attempt put it there), but the invitation email is still asking me to accept it.  Wondering whether my 'acceptance' emails have been sent too.
Comment 7 Kahlil Hodgson 2012-03-21 19:59:07 EDT
Damn! Just has the same error happen with a new meeting invitation so that probably rules out the above suggestion.  This time the new meeting does not appear in my calendar, though.
Comment 8 Milan Crha 2012-03-22 06:52:57 EDT
Oops, I'm sorry, this is pretty bad. I'm wrong with the "evolution-data-server-3.2.3-2 has it fixed". It doesn't, actually. There was no official release with the fix yet, thus this is really just a duplicate of bug #755791, thus I'm marking it as such.

*** This bug has been marked as a duplicate of bug 755791 ***

Note You need to log in before you can comment on or make changes to this bug.