Bug 804890 - [rhel5]: sar can not show correct name for virtio devices.
[rhel5]: sar can not show correct name for virtio devices.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysstat (Show other bugs)
5.9
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Peter Schiffer
Iveta Wiedermann
: Patch
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2012-03-20 01:06 EDT by Zhenyong(Jerry) Jiang
Modified: 2014-09-15 20:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the sysstat package did not support dynamically attributed major device numbers. Consequently, devices with these numbers were not listed in sar reports under their real names. With this update, support for dynamically attributed major device numbers has been added to sysstat. As a result, all devices now appear with their correct names in sar reports.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysstat-7.0.2-sysfs-devname.patch (1.90 KB, patch)
2012-06-22 11:17 EDT, Peter Schiffer
no flags Details | Diff
sysstat-7.0.2-devname.patch (5.74 KB, patch)
2014-02-13 12:44 EST, Peter Schiffer
no flags Details | Diff

  None (edit)
Description Zhenyong(Jerry) Jiang 2012-03-20 01:06:31 EDT
As the following system, it has local virtio disk named vda, but
when run "sar -d -p 1 1", sar just print the device name as "nodev". 

Customer wish it can be printed as it's own device name.

=====this is the example==========
[root@localhost ~]# cat /proc/partitions 
major minor  #blocks  name
 253     0  256000000 vda
 253     1     104391 vda1
 253     2  255891352 vda2
<snip>

[root@localhost ~]# sar -d -p 1 1
Linux 2.6.18-274.el5 (localhost.localdomain) 	03/18/2012
11:42:13 PM       DEV       tps  rd_sec/s  wr_sec/s  avgrq-sz  avgqu-sz     await     svctm     %util
11:42:14 PM     nodev      0.00      0.00      0.00      0.00      0.00      0.00      0.00      0.00
11:42:14 PM     nodev      0.00      0.00      0.00      0.00      0.00      0.00      0.00      0.00
11:42:14 PM     nodev      0.00      0.00      0.00      0.00      0.00      0.00      0.00      0.00
<snip>
==============================


Version-Release number of selected component (if applicable):
Red Hat Enterprise 5

How reproducible:
100%

Steps to Reproduce:
1. Setup a virtual guest with virtio disks.
2. Install the package sysstat.
3. Run "sar -d -p 1 1".

Actual results:

Command sar print the virtio device name as "nodev". 

Expected results:

Command sar should print the virtio device name as vdX. 

Additional info:

Another BZ804534 has been created for RHEL6. Note: virtio uses major number 253 in rhel5, uses 252 in rhel6.

Here is the patch for RHEL5:

--- /etc/sysconfig/sysstat.ioconf.orig	2012-03-19 01:02:11.000000000 -0400
+++ /etc/sysconfig/sysstat.ioconf	2012-03-19 01:00:10.000000000 -0400
@@ -234,6 +234,7 @@
 245:232:13:
 246:232:14:
 247:232:15:
+253:vd:*:0:a:32:*:16:virtio
 
 # 240..254: LOCAL/Experimental
 # 255: reserved for big dev_t expansion
Comment 4 RHEL Product and Program Management 2012-06-11 21:07:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2013-05-01 02:45:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2014-01-22 11:34:11 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 9 Peter Schiffer 2014-02-13 12:44:03 EST
Created attachment 862934 [details]
sysstat-7.0.2-devname.patch
Comment 14 errata-xmlrpc 2014-09-15 20:31:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1199.html

Note You need to log in before you can comment on or make changes to this bug.