Bug 804907 - libXi sets the event->display value to garbage
libXi sets the event->display value to garbage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libXi (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On:
Blocks: 842499
  Show dependency treegraph
 
Reported: 2012-03-20 02:20 EDT by Peter Hutterer
Modified: 2013-02-21 02:58 EST (History)
1 user (show)

See Also:
Fixed In Version: libXi-1.6.1-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cookie-display-check.c (1.34 KB, text/plain)
2012-07-31 20:48 EDT, Peter Hutterer
no flags Details
cookie-display-check.c (1.37 KB, text/plain)
2012-08-22 02:18 EDT, Peter Hutterer
no flags Details

  None (edit)
Description Peter Hutterer 2012-03-20 02:20:27 EDT
Description of problem:
The display member of XI2 events is garbage. The cookies themselves are fine, the actual event is uninitialised though.

http://cgit.freedesktop.org/xorg/lib/libXi/commit/?id=9419fe9f0b21232d342885a693fbf9222b5844e4

Version-Release number of selected component (if applicable):
libXi-1.3-3.el6

How reproducible:
Requires custom test program. select for XI2 events, call XGetEventData() on a cookie and then check the display member of the cookie data.
Comment 2 RHEL Product and Program Management 2012-07-16 18:49:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 3 Tomas Pelka 2012-07-24 09:31:53 EDT
(In reply to comment #0)
> [snipped]
> 
> How reproducible:
> Requires custom test program. select for XI2 events, call XGetEventData() on
> a cookie and then check the display member of the cookie data.

Peter do we have such program in hand?
Comment 4 Peter Hutterer 2012-07-31 20:48:15 EDT
Created attachment 601619 [details]
cookie-display-check.c

This program fails with an assertion error if the error manifests itself. It requires human input (moving the pointer when prompted) to ensure a even is received and can be checked.
Comment 6 Peter Hutterer 2012-08-22 02:18:18 EDT
Created attachment 606133 [details]
cookie-display-check.c

Updated for bugfix. mask.mask wasn't initialised, so depending on its contents the server may have replied with a BadValue error. Fixed by setting mask data to 0.
Comment 10 errata-xmlrpc 2013-02-21 02:58:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0294.html

Note You need to log in before you can comment on or make changes to this bug.