Bug 804909 - Mock instance get launched even when provider account is deleted.
Mock instance get launched even when provider account is deleted.
Status: CLOSED DUPLICATE of bug 796528
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Provaznik
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 02:33 EDT by Aziza Karol
Modified: 2014-08-04 18:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 02:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock (215.17 KB, image/png)
2012-03-20 02:34 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-03-20 02:33:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.configure mock and launch few mock instances.
2.delete mock provider account and then try launching mock instance

  
Actual results:
mock instances get launched and goes in new state. see attached screenshot


Expected results:
instances should not get launch when provider account is deleted.

Additional info:
rpm -qa | grep aeolus
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.0-43.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
Comment 1 Aziza Karol 2012-03-20 02:34:23 EDT
Created attachment 571296 [details]
mock
Comment 2 Jan Provaznik 2012-03-20 05:32:36 EDT
I was not able reproduce this BZ. Check, if a deployment can be launched is done on the deployment launch page. If a match is not found, a user should not be able to press "launch" button. So this BZ can occur only in following not-standard cases:
1) a user walks around pre launch check (by pressing "back" button after first launch)
2) a match is not found on real deployment launch because environment (providers, accounts, realms, hwps) have changed meantime.

A deployment should not be created at all if a match is not found - going to create a patch for this.

It's also slightly related to this BZ: https://bugzilla.redhat.com/show_bug.cgi?id=796528 - patch for this bug fixes instance state: instances will have "create_failed" state instead of "new" if launch fails.
Comment 3 Jan Provaznik 2012-03-20 05:48:46 EDT
Um, when thinking about it, there should be separate BZ for "deployment should not be created at all if a match is not found" - it might be different bug because I wasn't able to reproduce the bug describe by Aziz in original description.

Setting this bug to needinfo for more details.
Comment 4 Aziza Karol 2012-03-28 06:18:07 EDT
This issue is reproducible.

<akarol> jprovazn, first time i got this err and now when i launch its disabled..
<jprovazn> akarol: oh my god, I see how this can happen - when you select directly cloud resource zone on first click
<jprovazn> akarol: then you select resource zone on overview page, which is design flaw
<jprovazn> because a user can select any realm there
<jprovazn> this is a big problem :/
<jayg> that is a bit of a strong reaction for a web app  ;)
<akarol> jprovazn, yes.. 
<jayg> god commited some bad code huh?
<jprovazn> hehe

#rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.3-1.el6.noarch
Comment 5 Jan Provaznik 2012-03-28 06:25:27 EDT
This turned out to be duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=796528

(instance is stuck in 'new' state if match is not found)

I would suggest to close this as duplicity.
Comment 6 pushpesh sharma 2012-04-05 02:34:01 EDT
As per comment#5 marking this bug as duplicate of BZ#796528.Both bugs has common root cause.

*** This bug has been marked as a duplicate of bug 796528 ***

Note You need to log in before you can comment on or make changes to this bug.